Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360205 - Can't create pv dump file on host when guest crash
Summary: Can't create pv dump file on host when guest crash
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: ppc64le
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David Gibson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 08:51 UTC by Xujun Ma
Modified: 2016-09-05 01:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-05 01:07:39 UTC


Attachments (Terms of Use)

Description Xujun Ma 2016-07-26 08:51:20 UTC
Description of problem:
Can't create pv dump file on host when guest crash.

Version-Release number of selected component (if applicable):
hostkernel:3.10.0-470.el7.ppc64le
guestkernel:3.10.0-470.el7.ppc64le
qemu:qemu-kvm-rhev-2.6.0-13.el7.ppc64le


How reproducible:
100%

Steps to Reproduce:
1.Create xml file test.xml with commands:
<domain type='kvm'>
  <name>test</name>
  <memory unit='KiB'>10485760</memory>
  <currentMemory unit='KiB'>10485760</currentMemory>
  <vcpu placement='static'>1</vcpu>
  <os>
    <type arch='ppc64le' machine='pseries'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>coredump-destroy</on_crash>
   <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/mnt/RHEL-7.2.qcow2'/>
      <target dev='vda' bus='virtio'/>
    </disk>
    <graphics type='vnc' port='-1' autoport='yes' listen='0.0.0.0'>
      <listen type='address' address='0.0.0.0'/>
    </graphics>
    <video>
      <model type='vga' vram='9216' heads='1'/>
      <alias name='video0'/>
    </video>
   </devices>
</domain>
2.Define vm and boot up:
virsh define test.xml
virsh start test
3.Make guest crash:
(guest)echo c >/proc/sysrq-trigger
4.Check the crash file automatically created in host:
ls -lh /var/lib/libvirt/qemu/dump
Actual results:
there is no dump file.

Expected results:
create dump file automatically.

Additional info:

Comment 1 Thomas Huth 2016-07-26 09:38:45 UTC
I've got a question: Has the guest kernel been started with the "crashkernel=..." kernel option? In that case, this bug is likely related to BZ 1353459 ("qmp doesn't send guest panic event after guest crash"). Could you retry without the "crashkernel=..." option in that case?

Comment 3 Xujun Ma 2016-07-27 09:23:55 UTC
(In reply to Thomas Huth from comment #1)
> I've got a question: Has the guest kernel been started with the
> "crashkernel=..." kernel option? In that case, this bug is likely related to
> BZ 1353459 ("qmp doesn't send guest panic event after guest crash"). Could
> you retry without the "crashkernel=..." option in that case?

yes,it have.it's default kernel parameter for guest.
if delete the parameter ,the guest won't generate coredump file when trigger crash with command "echo c >/proc/sysrq-trigger",and there is no pvdump file in host too.

Comment 4 David Gibson 2016-08-04 05:07:20 UTC
Ok, last test eventually died due to the OOM killer.  Retrying with 8G of guest RAM.

Comment 5 Thomas Huth 2016-08-11 11:44:28 UTC
I've now tried to reproduce this issue, too. For me it is working as it should: When I start the guest kernel with "crashkernel=...", there is no dump in the host (which is ok since the guest already produced a dump, see BZ 1353459). But when I remove the "crashkernel=..." parameter at the grub interface, it works fine and I get a dump file in /var/lib/libvirt/qemu/dump in the host filesystem.

Xujun, could you maybe retry with qemu-kvm-rhev-2.6.0-19 (or newer) to see whether this was maybe just an issue with an older build of qemu-kvm-rhev?

Comment 6 Xujun Ma 2016-08-15 13:01:18 UTC
hi,Thomas

I found it's libvrt bug,which can be reproduced in libvirt-daemon.2.0.0-2.el7.ppc64le.

It has been fixed in libvirt-daemon.2.0.0.5.el7.ppc64le.

Comment 7 David Gibson 2016-09-05 01:07:39 UTC
Re: comment 6, closing as CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.