Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360182 - improve clarity of "Force Stop. Task explicitly stopped." message
Summary: improve clarity of "Force Stop. Task explicitly stopped." message
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: core
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 2
Assignee: Shubhendu Tripathi
QA Contact: Martin Kudlej
URL:
Whiteboard:
Depends On:
Blocks: Console-2-GA
TreeView+ depends on / blocked
 
Reported: 2016-07-26 07:44 UTC by Martin Bukatovic
Modified: 2016-08-23 19:58 UTC (History)
6 users (show)

Fixed In Version: rhscon-core-0.0.37-1.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:58:05 UTC


Attachments (Terms of Use)
screenshot 1: task details page after a timeout (deleted)
2016-07-26 07:46 UTC, Martin Bukatovic
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC
Gerrithub.io 285346 None None None 2016-07-27 03:55:38 UTC
Gerrithub.io 285347 None None None 2016-07-27 03:56:06 UTC

Description Martin Bukatovic 2016-07-26 07:44:25 UTC
Description of problem
======================

When RHSC 2.0 task is killed by console itself because of timeout, in a Task
Details page for the task, the message reporting this has the following format:

> Force Stop. Task: TASK_UID explicitly stopped.

This is the only information on the task detail page related to the
failure caused by the timeout.

The problem with the such error message is that it's not completely clear that:

* the task was killed by console itself (and not by a user or some other
  component)
* the reason for the force stop of the task is a timeout, the task took longer
  than expected

Version-Release
===============

rhscon-ceph-0.0.36-1.el7scon.x86_64
rhscon-core-selinux-0.0.36-1.el7scon.noarch
rhscon-core-0.0.36-1.el7scon.x86_64
rhscon-ui-0.0.50-1.el7scon.noarch

How reproducible
================

100%

Steps to Reproduce
==================

1. Install RHSC 2.0 following the documentation.
2. Start a task (eg. Initialize Node, Create Cluster) so that it will
   timeout.
3. Check the Task Details page when the task fails.

Actual results
==============

On the task detail page of the failed task, the last entry states:

> Force Stop. Task: a46cdd63-2f2e-403d-8cdc-ddb5c42fd506 explicitly stopped.

Expected results
================

On the task detail page of the failed task, the last entry states:

> Task a46cdd63-2f2e-403d-8cdc-ddb5c42fd506 has been killed after timeout

I'm not proposing a particular replacement, as I'm neither native speaker or
ui designer.

That said, It should be clear that:

* the task was killed/stopped by console itself
* console did this because of timeout

Comment 1 Martin Bukatovic 2016-07-26 07:46:53 UTC
Created attachment 1184086 [details]
screenshot 1: task details page after a timeout

Comment 2 Martin Bukatovic 2016-07-26 07:48:44 UTC
Could the design team propose suitable replacement for the current message here?

Comment 3 Shubhendu Tripathi 2016-07-27 03:49:36 UTC
I am changing the message as "Force Stop. Task: <id> explicitly stopped due to timeout."

Comment 5 Martin Bukatovic 2016-08-01 14:59:26 UTC
(In reply to Shubhendu Tripathi from comment #3)
> I am changing the message as "Force Stop. Task: <id> explicitly stopped due
> to timeout."

Since it seems that the format of the message has been decided and it looks ok,
I'm removing the needinfo flag.

Comment 6 Martin Kudlej 2016-08-03 11:39:44 UTC
Tested with
ceph-ansible-1.0.5-32.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.39-1.el7scon.x86_64
rhscon-core-0.0.39-1.el7scon.x86_64
rhscon-core-selinux-0.0.39-1.el7scon.noarch
rhscon-ui-0.0.51-1.el7scon.noarch
and task ID is missing in error message:
"Force Stop. Task explicitly stopped due to timeout."
-->ASSIGNED

Comment 7 Shubhendu Tripathi 2016-08-03 12:15:08 UTC
Martin, so the message comes from two different places in USM. In one place from where this got generated we dont have task id available and so not in the message.

Also this BZ was just to make message more clearer which was already existing.

This is actually not an issue should be verified as its as per the code in USM.

Comment 8 Martin Kudlej 2016-08-03 12:33:03 UTC
Closing as Verified after discussion.

Comment 10 errata-xmlrpc 2016-08-23 19:58:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.