Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360177 - lsmcli: local-disk-list reports error when listing DELL perc device
Summary: lsmcli: local-disk-list reports error when listing DELL perc device
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libstoragemgmt
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Gris Ge
QA Contact: Bruno Goncalves
URL:
Whiteboard:
Depends On:
Blocks: 1304953
TreeView+ depends on / blocked
 
Reported: 2016-07-26 07:30 UTC by Bruno Goncalves
Modified: 2016-11-04 06:10 UTC (History)
1 user (show)

Fixed In Version: libstoragemgmt-1.3.3-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 06:10:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2415 normal SHIPPED_LIVE libstoragemgmt bug fix update 2016-11-03 13:57:59 UTC

Description Bruno Goncalves 2016-07-26 07:30:58 UTC
Description of problem:
Using lsmcli  local-disk-list returns error, when running on server with DELL perc device.

# lsmcli  local-disk-list
LIB_BUG(1): Got corrupted SCSI SBC Device Characteristics VPD page, expected page code is 177 but got 46

Version-Release number of selected component (if applicable):
libstoragemgmt-1.3.2-7.el7

How reproducible:
100%

Steps to Reproduce:
1.List local disks on a server with DELL perc disk
# lsmcli  local-disk-list
LIB_BUG(1): Got corrupted SCSI SBC Device Characteristics VPD page, expected page code is 177 but got 46

Comment 2 Gris Ge 2016-07-27 12:16:23 UTC
Patch has been sent to upstream:
https://github.com/libstorage/libstoragemgmt/pull/176

Comment 4 Bruno Goncalves 2016-08-02 12:26:06 UTC
Verified on libstoragemgmt-1.3.3-1.el7

# lsscsi
[1:2:0:0]    disk    DELL     PERC H710P       3.13  /dev/sda 
[6:0:0:0]    cd/dvd  PLDS     DVD-ROM DS-8D9SH UD51  /dev/sr0 

# lsmcli  local-disk-list
Path     | SCSI VPD 0x83                    | Revolutions Per Minute | Link Type 
---------------------------------------------------------------------------------
/dev/sda | 6d4ae52096419a0019a77ec420e4c997 | No Support             | No Support

Comment 6 errata-xmlrpc 2016-11-04 06:10:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2415.html


Note You need to log in before you can comment on or make changes to this bug.