Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360131 - kdump: dumping to ssh target fails when using a customized UserKnownHostsFile
Summary: kdump: dumping to ssh target fails when using a customized UserKnownHostsFile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 05:56 UTC by Qiao Zhao
Modified: 2017-08-01 21:06 UTC (History)
4 users (show)

Fixed In Version: dracut-033-496.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 21:06:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2076 normal SHIPPED_LIVE dracut bug fix and enhancement update 2017-08-01 18:36:59 UTC

Description Qiao Zhao 2016-07-26 05:56:58 UTC
Description of problem:
Network special nic card(qlcnic) test failed.

[console]
[    0.000000] Ke32.x86_64 root=/dev/mapper/rhel_hp--dl580g7--01-root ro rd.lvm.lv=rhel_hp-dl580g7-01/root rd.lvm.lv=rhel_hp-dl580g7-01/swap console=ttyS1,115200n81 LANG=en_US.UTF-8 irqpoll nr_cpus=1 reset_devices cgroup_dimemory mce=off numa=off udev.children-max=2 panic=10 rootflags=nofail acpi_no_memhotplug transparent_hugepage=never disable_cpu_apicid=0 elfcorehdr=867712K
...
[  OK  ] Started dracut pre-pivot and cleanup hook.
         Starting Kdump Vmcore Save Service...
kdump: saving to root@192.168.1.52:/mnt/testarea/ssh/hp-dl580g7-01.rhts.eng.pek2.redhat.com/192.168.1.10-2016-07-26-01:41:25
kdump: saving vmcore failed
[FAILED] Failed to start Kdump Vmcore Save Service.
See 'systemctl status kdump-capture.service' for details.
...
kdump:/# systemctl -l status kdump-capture.service
● kdump-capture.service - Kdump Vmcore Save Service
   Loaded: loaded (/usr/lib/systemd/system/kdump-capture.service; static; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2016-07-26 01:41:25 EDT; 4min 1s ago
  Process: 563 ExecStart=/bin/kdump.sh (code=exited, status=1/FAILURE)
 Main PID: 563 (code=exited, status=1/FAILURE)

Jul 26 01:41:25 hp-dl580g7-01.rhts.eng.pek2.redhat.com systemd[1]: Starting Kdump Vmcore Save Service...
Jul 26 01:41:25 hp-dl580g7-01.rhts.eng.pek2.redhat.com systemd[1]: kdump-capture.service: main process exited, code=exited, status=1/FAILURE
Jul 26 01:41:25 hp-dl580g7-01.rhts.eng.pek2.redhat.com systemd[1]: Failed to start Kdump Vmcore Save Service.
Jul 26 01:41:25 hp-dl580g7-01.rhts.eng.pek2.redhat.com systemd[1]: Unit kdump-capture.service entered failed state.
Jul 26 01:41:25 hp-dl580g7-01.rhts.eng.pek2.redhat.com systemd[1]: Triggering OnFailure= dependencies of kdump-capture.service.
Jul 26 01:41:25 hp-dl580g7-01.rhts.eng.pek2.redhat.com systemd[1]: kdump-capture.service failed.
[/console]

# grep -v ^# /etc/kdump.conf
ssh root@192.168.1.52
sshkey /root/.ssh/id_rsa
core_collector makedumpfile -F -l --message-level 1 -d 31
path /mnt/testarea/ssh/hp-dl585g7-02.rhts.eng.pek2.redhat.com
default shell

We can't analyze what causes this error.

Version-Release number of selected component (if applicable):
dracut-033-449.el7
kexec-tools-2.0.7-47.el7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Dave Young 2017-04-04 03:56:37 UTC
This has been solved in a dracut commit below, thus move to dracut component..

commit 32f5af2f5e20ee982745262c444c50b20bfb4c01
Author: Tong Li <tonli@redhat.com>
Date:   Wed Nov 30 17:05:57 2016 +0800

    95ssh-client: attempt to copy UserKnownHostsFile to kdump's initramfs

Comment 9 errata-xmlrpc 2017-08-01 21:06:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2076


Note You need to log in before you can comment on or make changes to this bug.