Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1360119 - Fail to edit the guest's XML associated with a saved state file with virsh save-image-edit command
Summary: Fail to edit the guest's XML associated with a saved state file with virsh sa...
Keywords:
Status: CLOSED DUPLICATE of bug 1229255
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1229255
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 04:35 UTC by yisun
Modified: 2016-07-27 02:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1229255
Environment:
Last Closed: 2016-07-27 02:45:06 UTC


Attachments (Terms of Use)

Comment 1 yisun 2016-07-26 04:37:58 UTC
per https://bugzilla.redhat.com/show_bug.cgi?id=1229255#c10
This issue also reproduced on x86_64 platform(which doesn't have problem before), so clone this bug here for tracking.

Comment 3 Andrea Bolognani 2016-07-26 07:48:40 UTC
(In reply to yisun from comment #1)
> per https://bugzilla.redhat.com/show_bug.cgi?id=1229255#c10
> This issue also reproduced on x86_64 platform(which doesn't have problem
> before), so clone this bug here for tracking.

Does it make sense to have two separate bugs track this?
Wouldn't it be less confusing to just move Bug 1229255 to
Hardware: All and keep tracking the issue there?

Comment 4 Andrea Bolognani 2016-07-26 11:28:38 UTC
Guannan mentioned that a new bug was filed because this issue
didn't seem to affect libvirt < 2.0.0 on x86.

I actually think that there has been no regression on x86,
and that the bug was affecting both architectures even before;
what might have happened is that the bug has been made easier
to trigger because the domain XML has become bigger on x86.

It would be very interesting to take the domain XML from
libvirt 2.0.0 and use it to define a guest on earlier libvirt,
and see whether performing the same steps on both libvirt
versions has the same result.

Comment 5 yisun 2016-07-27 02:45:06 UTC
(In reply to Andrea Bolognani from comment #4)
> Guannan mentioned that a new bug was filed because this issue
> didn't seem to affect libvirt < 2.0.0 on x86.
> 
> I actually think that there has been no regression on x86,
> and that the bug was affecting both architectures even before;
> what might have happened is that the bug has been made easier
> to trigger because the domain XML has become bigger on x86.
> 
> It would be very interesting to take the domain XML from
> libvirt 2.0.0 and use it to define a guest on earlier libvirt,
> and see whether performing the same steps on both libvirt
> versions has the same result.

Your assumption is correct, with same xml, it reproduced on previous libvirt versions. I'll close this bug, add comment to original bug and change the "platform" from "ppc" to "all". thx. 





 ============ libvirt-1.2.17-13.el7.x86_64 ============

[root@localhost 1.2.17-13.el7]# service libvirtd restart
Redirecting to /bin/systemctl restart  libvirtd.service
[root@localhost 1.2.17-13.el7]# rpm -qa | grep libvirt-1
libvirt-1.2.17-13.el7.x86_64
[root@localhost 1.2.17-13.el7]# rpm -qa | grep libvirt-1^C
[root@localhost 1.2.17-13.el7]# virsh save-image-edit /tmp/vm.save 
error: operation failed: new xml too large to fit in file
Failed. Try again? [y,n,f,?]: 
error: operation failed: new xml too large to fit in file

[root@localhost 1.2.17-13.el7]# virsh save-image-define /tmp/vm.save /tmp/old_vm.xml --running
error: Failed to update /tmp/vm.save
error: operation failed: new xml too large to fit in file


 ============ libvirt-1.3.5-1.el7.x86_64 ============
[root@localhost 1.3.5-1.el7]# rpm -qa | grep libvirt-1
libvirt-1.3.5-1.el7.x86_64
[root@localhost 1.3.5-1.el7]# service libvirtd restart
Redirecting to /bin/systemctl restart  libvirtd.service
[root@localhost 1.3.5-1.el7]# virsh save-image-edit /tmp/vm.save 
error: operation failed: new xml too large to fit in file
Failed. Try again? [y,n,f,?]: 
error: operation failed: new xml too large to fit in file

[root@localhost 1.3.5-1.el7]# vim /tmp/old_vm.xml 
[root@localhost 1.3.5-1.el7]# virsh save-image-define /tmp/vm.save /tmp/old_vm.xml --running
error: Failed to update /tmp/vm.save
error: operation failed: new xml too large to fit in file

*** This bug has been marked as a duplicate of bug 1229255 ***


Note You need to log in before you can comment on or make changes to this bug.