Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359971 - [dev-preview] Builds taking an average of 30 seconds to start
Summary: [dev-preview] Builds taking an average of 30 seconds to start
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Build
Version: 3.x
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Cesar Wong
QA Contact: Wang Haoran
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-26 02:39 UTC by Steve Speicher
Modified: 2016-07-28 17:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-28 17:31:34 UTC


Attachments (Terms of Use)

Description Steve Speicher 2016-07-26 02:39:21 UTC
Description of problem:

From the point of time I start a build, it remains in pending state for almost 30 seconds consistently. This seems like too long considering there is plenty of capacity and it is subsequent builds.


OpenShift Master:
v3.2.1.10-1-g668ed0a
Kubernetes Master:
v1.2.0-36-g4a3f9c5


How reproducible:
Simple grab the Wildfly 10 builder and take the defaults, including the sample.
Repeatedly initiate a new build, observer the wait time for it to start.

Expected results:
I would expect < 5 seconds for it to be in pending state.

Comment 1 Cesar Wong 2016-07-28 02:11:31 UTC
I am not able to reproduce this behavior on dev preview.

Steve, are you still seeing this?

Comment 2 Steve Speicher 2016-07-28 17:31:34 UTC
This is not happening for me either now, I'm not sure what has changed...but thanks!


Note You need to log in before you can comment on or make changes to this bug.