Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359919 - Base url incorrect
Summary: Base url incorrect
Keywords:
Status: CLOSED EOL
Alias: None
Product: RDO
Classification: Community
Component: distribution
Version: Kilo
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: trunk
Assignee: Lars Kellogg-Stedman
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-25 19:13 UTC by Waheed
Modified: 2017-06-01 00:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-01 00:51:38 UTC


Attachments (Terms of Use)

Description Waheed 2016-07-25 19:13:39 UTC
Description of problem:

i was trying to install openstack-kilo single-node on RHEL7 using the official documents
https://www.rdoproject.org/install/quickstart/
i have changed the url with expect fedro url
sudo yum install -y https://repos.fedorapeople.org/repos/openstack/openstack-kilo/rdo-release-kilo-2.noarch.rpm
after the successfully execution of above command i have tried to update using following command "sudo yum update -y"
i was not abled to update successfully and got this error
failure: repodata/repomd.xml from openstack-kilo: [Errno 256] No more mirrors to try.
http://mirror.centos.org/centos/7Server/cloud/x86_64/openstack-kilo/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found


Version-Release number of selected component (if applicable):


How reproducible:
follow up the documentation to setup single-node openstack-kilo


Steps to Reproduce:
1.sudo yum install -y https://repos.fedorapeople.org/repos/openstack/openstack-kilo/rdo-release-kilo-2.noarch.rpm 
2.sudo yum install -y


Actual results:
failure: repodata/repomd.xml from openstack-kilo: [Errno 256] No more mirrors to try.
http://mirror.centos.org/centos/7Server/cloud/x86_64/openstack-kilo/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

Expected results:
must be updated successfully

Additional info:
i have fixed this issue after changing the base url rdo-release.repo and rd0-testing.repo file
The actual url is this
http://mirror.centos.org/centos/7/cloud/x86_64/openstack-kilo/repodata/repomd.xml
but in file it was 
http://mirror.centos.org/centos/7Server/cloud/x86_64/openstack-kilo/repodata/repomd.xml
due to somereason Server word is extra with 7 in url
i have replace the 7Server with only 7 in rdo-release.repo ,rd0-testing.repo file and i was abled to openstack-kilo successfully
Thanks
 Regrads waheed

Comment 1 Alan Pevec 2017-06-01 00:51:38 UTC
This has been fixed in https://github.com/rdo-infra/centos-release-openstack/commit/3dab5dc51986737b0d84a1e3452374db2c606a49

Since Kilo is EOL, closing this.


Note You need to log in before you can comment on or make changes to this bug.