Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359913 - Greybird theme does not render fonts, sliders etc well in XFCE
Summary: Greybird theme does not render fonts, sliders etc well in XFCE
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: greybird
Version: 24
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-25 18:21 UTC by Walter Francis
Modified: 2016-09-01 03:20 UTC (History)
3 users (show)

Fixed In Version: greybird-3.20.0-2.fc25 greybird-3.20.0-2.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-31 16:30:27 UTC


Attachments (Terms of Use)
Greybird theme, missing elements, images, fonts etc (deleted)
2016-07-25 18:21 UTC, Walter Francis
no flags Details
Adwaita theme, looks fine (deleted)
2016-07-25 18:22 UTC, Walter Francis
no flags Details

Description Walter Francis 2016-07-25 18:21:59 UTC
Created attachment 1183910 [details]
Greybird theme, missing elements, images, fonts etc

Description of problem:  Greybird in XFCE on Fedora 23 and Fedora 24 has rendering issues.  Places where text is separated is all squished together, some GUI elements like sliders are missing, etc.

Version-Release number of selected component (if applicable):

greybird-xfwm4-theme-1.6.2-2
greybird-gtk2-theme-1.6.2-2
greybird-gtk3-theme-1.6.2-2


How reproducible:  100%


Steps to Reproduce:
1.  Install Fedora 24 (I use XFCE spin)
2.  Launch pavucontrol
3.  Change XFCE Settings->Appearance->Style to Greybird

Actual results:

Some GTK screens, such as pavucontrol in this example, are unusable with bad looking fonts.


Expected results:

Only styling changes, no missing elements, etc.


Additional info:  Greybird is not the only theme this happens on, but happens to be the one I use.  Albatross, Bluebird, Raleigh and ALL XFCE-* styles act this way.  There could be other Fedora themes that have this issue as well, but these are the ones that seem to be installed by default.

Comment 1 Walter Francis 2016-07-25 18:22:30 UTC
Created attachment 1183911 [details]
Adwaita theme, looks fine

Comment 2 Mukundan Ragavan 2016-07-26 02:03:47 UTC
This is because of lack of GTK-3.20+ support in the released version of greybird (and other) themes.

There are some patches/commits on upstream git repo - but I have not had time to test it. I can take a look over the course of this week.


A temporary solution would be use either Adwaita or Clearlooks - both of which should work fine.

Comment 3 Kevin Fenzi 2016-07-26 02:08:37 UTC
So, this is most likely due to changes in gtk3. The 3rd party themes lag behind adjusting to new gtk3 changes. Adwaita is the reference theme that gnome uses so it's adjusted along with gtk3. 

All that said, there is a slightly newer greybird available. 

https://koji.fedoraproject.org/koji/taskinfo?taskID=15017453

Does that help your use cases any?
(Thats only with 3.18 support, and Fedora 24 has 3.20, so theres likely still issues)

Comment 4 Mukundan Ragavan 2016-07-26 02:15:28 UTC
I think we might have to run a trial with 3.20 branch - https://github.com/shimmerproject/Greybird/tree/gtk3.20

The one with 3.18 might not even be worth updating in Fedora - at least as far as I can tell from my testing a while back using the git repo.

Comment 5 Walter Francis 2016-07-26 16:27:49 UTC
(In reply to Kevin Fenzi from comment #3)
> So, this is most likely due to changes in gtk3. The 3rd party themes lag
> behind adjusting to new gtk3 changes. Adwaita is the reference theme that
> gnome uses so it's adjusted along with gtk3. 
> 
> All that said, there is a slightly newer greybird available. 
> 
> https://koji.fedoraproject.org/koji/taskinfo?taskID=15017453
> 
> Does that help your use cases any?
> (Thats only with 3.18 support, and Fedora 24 has 3.20, so theres likely
> still issues)

Hmm, I updated the following RPMs from your build:

greybird-gtk2-theme-3.18.0-1.fc24.noarch.rpm
greybird-gtk3-theme-3.18.0-1.fc24.noarch.rpm
greybird-xfwm4-theme-3.18.0-1.fc24.noarch.rpm

And switched to it in XFCE; still looks the same as before with missing elements etc.  Anything else I need to do?  Restart XFCE?  Did I get the appropriate RPMS?  thanks Nirik :)

Comment 6 Kevin Fenzi 2016-07-26 16:52:13 UTC
Yeah, it doesn't seem to help much... the changes in gtk3-3.20 were pretty large. :(

Comment 7 Mukundan Ragavan 2016-08-01 01:20:58 UTC
Can you try this?

http://koji.fedoraproject.org/koji/taskinfo?taskID=15087973

This is from gtk3.20 branch and should be better - not perfect. But, I am sure extra testing is beneficial.

Comment 8 Walter Francis 2016-08-03 15:44:08 UTC
(In reply to Mukundan Ragavan from comment #7)
> Can you try this?
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=15087973
> 
> This is from gtk3.20 branch and should be better - not perfect. But, I am
> sure extra testing is beneficial.

Sorry about the late response, I've tried this today and it looks good in XFCE!

Comment 9 Mukundan Ragavan 2016-08-03 22:03:09 UTC
(In reply to Walter Francis from comment #8)
> (In reply to Mukundan Ragavan from comment #7)
> > Can you try this?
> > 
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=15087973
> > 
> > This is from gtk3.20 branch and should be better - not perfect. But, I am
> > sure extra testing is beneficial.
> 
> Sorry about the late response, I've tried this today and it looks good in
> XFCE!

Glad to hear that. I might update that after a bit of testing. I think this is something that is badly needed considering Greybird is in xfce spin .. :(

Comment 10 Walter Francis 2016-08-04 02:33:47 UTC
(In reply to Mukundan Ragavan from comment #9)
> (In reply to Walter Francis from comment #8)
> > (In reply to Mukundan Ragavan from comment #7)
> > > Can you try this?
> > > 
> > > http://koji.fedoraproject.org/koji/taskinfo?taskID=15087973
> > > 
> > > This is from gtk3.20 branch and should be better - not perfect. But, I am
> > > sure extra testing is beneficial.
> > 
> > Sorry about the late response, I've tried this today and it looks good in
> > XFCE!
> 
> Glad to hear that. I might update that after a bit of testing. I think this
> is something that is badly needed considering Greybird is in xfce spin .. :(

Feel free to keep this open and post any test builds etc, I'll be happy to help on my end if it's of any use.  I'm only using it in XFCE in F24, I'm honestly not sure what the other builds are for or how to 'use' them ;)

Comment 11 Fedora Update System 2016-08-19 01:57:48 UTC
greybird-3.20.0-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1d7dc6b015

Comment 12 Fedora Update System 2016-08-19 01:59:01 UTC
greybird-3.20.0-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5d8490eb50

Comment 13 Fedora Update System 2016-08-19 16:50:50 UTC
greybird-3.20.0-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5d8490eb50

Comment 14 Fedora Update System 2016-08-19 23:21:46 UTC
greybird-3.20.0-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1d7dc6b015

Comment 15 Fedora Update System 2016-08-31 16:30:19 UTC
greybird-3.20.0-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2016-09-01 03:20:30 UTC
greybird-3.20.0-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.