Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359911 - Cannot generate overcloud images with liberty
Summary: Cannot generate overcloud images with liberty
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: RDO
Classification: Community
Component: openstack-tripleo
Version: Liberty
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: trunk
Assignee: James Slagle
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-25 18:02 UTC by David Hill
Modified: 2017-06-18 12:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-18 12:09:34 UTC


Attachments (Terms of Use)

Description David Hill 2016-07-25 18:02:44 UTC
Description of problem:
Cannot generate overcloud images with liberty because kilo is hardcoded in overcloud_image.py in RDO_RELEASE.

--- a/tripleoclient/v1/overcloud_image.py
+++ b/tripleoclient/v1/overcloud_image.py
@@ -448,7 +448,7 @@ class BuildOvercloudImage(command.Command):
             self._set_env_var(env_vars, 'FS_TYPE', 'xfs')
 
             if env_vars.get('RHOS') == '0':
-                env_vars['RDO_RELEASE'] = 'kilo'
+                env_vars['RDO_RELEASE'] = 'liberty'
                 dib_common_elements.extend([
                     'epel',
                     'rdo-release',


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install rdo liberty packages and try to build overcloud images.
2.
3.

Actual results:
Fails

Expected results:
Succeeds

Additional info:
What am I missing?

Comment 1 Alan Pevec 2016-07-25 21:20:26 UTC
This is fixed by a patch in RDO Liberty CloudSIG builds: http://cbs.centos.org/koji/buildinfo?buildID=7087

You are probably using RDO Trunk Liberty packages built from pure upstream stable/liberty sources, please report this issue upstream at https://bugs.launchpad.net/tripleo/+filebug

Comment 2 Christopher Brown 2017-06-18 12:09:34 UTC
Fixed upstream.


Note You need to log in before you can comment on or make changes to this bug.