Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359824 - 2.0 : Couldn't start a new monitor while adding via manual steps to a cluster with customized cluster name
Summary: 2.0 : Couldn't start a new monitor while adding via manual steps to a cluster...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Samuel Just
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-25 13:55 UTC by Vasishta
Modified: 2017-07-30 15:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-25 15:09:14 UTC


Attachments (Terms of Use)

Description Vasishta 2016-07-25 13:55:07 UTC
Description of problem:
Couldn't start a new monitor while adding via manual steps to a cluster with customized cluster name

Version-Release number of selected component (if applicable):
ceph version 10.2.2-27.el7cp

How reproducible:
always

Steps to Reproduce:
1.Follow below doc to add a new monitor (via CLI) to a cluster with custom cluster name - in my case, it was 'master': 
Doc : https://access.qa.redhat.com/documentation/en/red-hat-ceph-storage/2/administration-guide/#adding_a_monitor_with_the_command_line_interface (see Section 6.1.3)


Actual results: (After Step 10)

# ceph-mon -i cephqe7 --public-addr 10.70.44.48:6789 --pid-file /var/run/ceph/mon.cephqe7.pid
2016-07-25 18:02:16.348198 7fd7fc03e4c0 -1 did not load config file, using default settings.
monitor data directory at '/var/lib/ceph/mon/ceph-cephqe7' does not exist: have you run 'mkfs'?

Expected results:
Monitor must get started

Additional info:

When mkfs was run (Step 9 same doc) it could successfully create contents of monitor data in directory /var/lib/ceph/mon/master-cephqe7 that is, /var/lib/ceph/mon/<cluster_name>-<node_ID>

# ceph-mon -i cephqe7 --mkfs --monmap /tmp/ceph/ceph_mon_map.out --keyring /tmp/ceph/ceph_keyring.out -c /etc/ceph/master.conf
ceph-mon: set fsid to bca06dbe-9499-4dc3-9cb2-92717274848f
ceph-mon: created monfs at /var/lib/ceph/mon/master-cephqe7 for mon.cephqe7


But when an attempt is made to start monitor as mentioned above, It is expecting contents of monitor data to be present in var/lib/ceph/mon/ceph-cephqe7 that is, var/lib/ceph/mon/ceph-<node_ID> instead of /ceph/mon/<cluster_name>-<node_ID>

Comment 2 Samuel Just 2016-07-25 14:44:49 UTC
ceph-mon -i cephqe7 --public-addr 10.70.44.48:6789 --pid-file /var/run/ceph/mon.cephqe7.pid
2016-07-25 18:02:16.348198 7fd7fc03e4c0 -1 did not load config file, using default settings.
monitor data directory at '/var/lib/ceph/mon/ceph-cephqe7' does not exist: have you run 'mkfs'?

You didn't specify the master.conf config file...  This seems to be the correct behavior.

Comment 3 Vasishta 2016-07-25 15:09:14 UTC
Hi Samuel,

Yes, I didn't mentioned about conf file.

Correct version I must have used is -
ceph-mon -i cephqe7 --public-addr <IP addr:Port> --pid-file /var/run/ceph/mon.cephqe7.pid -c /etc/ceph/master.conf
Working perfect.

Extremely Sorry.


Thanks,
Vasishta P Shatsry


Note You need to log in before you can comment on or make changes to this bug.