Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359810 - cmd 'dnf install I_dont_exit zsh' installs nothing
Summary: cmd 'dnf install I_dont_exit zsh' installs nothing
Keywords:
Status: CLOSED DUPLICATE of bug 1197456
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 24
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-25 13:32 UTC by Petr Sklenar
Modified: 2016-07-27 15:04 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-25 14:50:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1107737 None None None Never

Internal Links: 1107737

Description Petr Sklenar 2016-07-25 13:32:20 UTC
Description of problem:
cmd 'dnf install I_dont_exit zsh' installs nothing

Version-Release number of selected component (if applicable):
dnf-1.1.9-2.fc24.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf install I_dont_exit zsh

Actual results:
zsh is not installed as 'I_dont_exit' is not available
this is regression

see log:

[root@qeos-77 KerberosSupport]# rpm -q zsh
package zsh is not installed
[root@qeos-77 KerberosSupport]# dnf install zsh wtf
Last metadata expiration check: 2:59:33 ago on Mon Jul 25 06:27:30 2016.
No package wtf available.
Error: Unable to find a match.
[root@qeos-77 KerberosSupport]# dnf install zsh
Last metadata expiration check: 2:59:39 ago on Mon Jul 25 06:27:30 2016.
Dependencies resolved.
============================================================================================================================================================================
 Package                               Arch                                     Version                                      Repository                                Size
============================================================================================================================================================================
Installing:
 zsh                                   x86_64                                   5.2-5.fc24                                   fedora                                   2.7 M

Transaction Summary
============================================================================================================================================================================
Install  1 Package

Total download size: 2.7 M
Installed size: 6.2 M
Is this ok [y/N]: ^COperation aborted.
[root@qeos-77 KerberosSupport]# rpm -q dnf
dnf-1.1.9-2.fc24.noarch


Expected results:
it installs zsh and write info that 'I_dont_exit zsh' is not available

Additional info:

Comment 1 Igor Gnatenko 2016-07-25 13:35:01 UTC
[ignatenk@ignatenko pygpgme]$ sudo dnf install wtf zsh
Last metadata expiration check: 0:34:16 ago on Mon Jul 25 14:59:59 2016.
No package wtf available.
Error: Unable to find a match.
[ignatenk@ignatenko pygpgme]$ sudo dnf --setopt=strict=false install wtf zsh
Last metadata expiration check: 0:34:28 ago on Mon Jul 25 14:59:59 2016.
No package wtf available.
Dependencies resolved.
================================================================================
 Package        Arch              Version               Repository         Size
================================================================================
Installing:
 zsh            x86_64            5.2-5.fc24            fedora            2.7 M

Transaction Summary
================================================================================
Install  1 Package

Total download size: 2.7 M
Installed size: 6.2 M
Is this ok [y/N]: n
Operation aborted.

Comment 2 Petr Sklenar 2016-07-25 14:04:06 UTC
Its not user friendly. I am expecting similar usage like yum and yum installs such a packages.

Comment 3 Igor Gnatenko 2016-07-25 14:50:00 UTC
It has been even implemented in yum, see: https://bugzilla.redhat.com/show_bug.cgi?id=1274211

definitely NOTABUG.

Comment 4 Honza Silhan 2016-07-25 15:33:32 UTC
Good news for you is that strict=0 will be default behavior when you invoke `/usr/bin/yum` from `yum-dnf` with DNF backend.

*** This bug has been marked as a duplicate of bug 1197456 ***


Note You need to log in before you can comment on or make changes to this bug.