Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359738 - ipa-replica-install --domain=<IPA primary domain> option does not work
Summary: ipa-replica-install --domain=<IPA primary domain> option does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Abhijeet Kasurde
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-25 11:12 UTC by Petr Spacek
Modified: 2018-08-23 20:29 UTC (History)
6 users (show)

Fixed In Version: ipa-4.4.0-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:59:07 UTC


Attachments (Terms of Use)
console.log (deleted)
2016-09-06 10:46 UTC, Abhijeet Kasurde
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Petr Spacek 2016-07-25 11:12:07 UTC
Description of problem:
ipa-replica-install --domain=<IPA primary domain> option does not work and always fails.

Version-Release number of selected component (if applicable):
ipa-server-4.4.0-2.1.el7.x86_64

How reproducible:
100 %

Steps to Reproduce:
Run
$ ipa-replica-install --admin-password=<password> --principal=admin --domain=<IPA primary domain> --unattended --setup-dns --auto-forwarders

Actual results:
Checking DNS domain dom-076.abc.idm.lab.eng.brq.redhat.com, please wait ...
Usage: ipa-replica-install [options] REPLICA_FILE

ipa-replica-install: error: option --domain: DNS zone <IPA primary domain> already exists in DNS and is handled by server(s): <some IPA servers>
ipa.ipapython.install.cli.install_tool(Replica): ERROR    The ipa-replica-install command failed. See /var/log/ipareplica-install.log for more information


Expected results:
Installation should be allowed if all the options are correct.


Additional info:
This is a regression as this used to work in the past.

Workaround for domain level 1 is easy: Install IPA client first and then run ipa-replica-install without --domain option.

Comment 3 Petr Spacek 2016-07-25 13:54:28 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6130

Comment 4 Jan Cholasta 2016-07-29 05:38:26 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/6eb9eb730350937692a442b66e4d79d3ebd4eb01

Comment 6 Abhijeet Kasurde 2016-09-06 10:46:51 UTC
Created attachment 1198167 [details]
console.log

Verified using IPA version::

ipa-server-4.4.0-9.el7.x86_64

Marking BZ as verified.

Comment 8 errata-xmlrpc 2016-11-04 05:59:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.