Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359668 - Failed to import VM from any source [NEEDINFO]
Summary: Failed to import VM from any source
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.0.2
Hardware: x86_64
OS: Linux
urgent
urgent vote
Target Milestone: ovirt-4.0.2
: 4.0.2.4
Assignee: Yevgeny Zaspitsky
QA Contact: Raz Tamir
URL:
Whiteboard:
: 1360321 1360376 (view as bug list)
Depends On:
Blocks: 1302427 1358802 1359202 1360686
TreeView+ depends on / blocked
 
Reported: 2016-07-25 09:21 UTC by Meni Yakove
Modified: 2017-01-31 10:16 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-12 14:22:00 UTC
oVirt Team: Network
eedri: needinfo? (amarchuk)
rule-engine: ovirt-4.0.z+
ykaul: blocker+
rule-engine: planning_ack+
michal.skrivanek: devel_ack+
myakove: testing_ack+


Attachments (Terms of Use)
ebgine log (deleted)
2016-07-25 09:21 UTC, Meni Yakove
no flags Details
sosreport from the engine (deleted)
2016-07-26 16:06 UTC, Nikolai Sednev
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 61325 ovirt-engine-4.0 MERGED engine: use cluster.dcId if params.dcId isn't set 2016-07-27 12:18:39 UTC
oVirt gerrit 61326 ovirt-engine-4.0 ABANDONED engine: improve problems reporting in MacPoolPerDc 2017-01-31 10:16:57 UTC
oVirt gerrit 61487 ovirt-engine-4.0.2 MERGED engine: use cluster.dcId if params.dcId isn't set 2016-07-27 12:46:22 UTC
Red Hat Bugzilla 1359667 None None None Never
Red Hat Bugzilla 1360686 None None None Never

Internal Links: 1359667 1360686

Description Meni Yakove 2016-07-25 09:21:21 UTC
Created attachment 1183644 [details]
ebgine log

Description of problem:
Failed to import VM from export domain via rest

Version-Release number of selected component (if applicable):
rhevm-4.0.2-0.1.rc.el7ev.noarch


Steps to Reproduce:
POST to:
jenkins-vm-06.scl.lab.tlv.redhat.com/ovirt-engine/api/storagedomains/<export_domain_id>/vms/<vm_id>/import

<action>
    <async>false</async>
    <cluster>
        <name><cluster_name></name>
    </cluster>
    <grace_period>
        <expiry>10</expiry>
    </grace_period>
    <storage_domain>
        <name><storage_domain_name></name>
    </storage_domain>
</action>

Additional info:
2016-07-25 10:51:12,087 ERROR [org.ovirt.engine.core.bll.exportimport.ImportVmCommand] (default task-27) [] Command 'org.ovirt.engine.core.bll.exportimport.ImportVmCommand' failed: Coding error, pool for requested GUID does not exist
2016-07-25 10:51:12,088 ERROR [org.ovirt.engine.core.bll.exportimport.ImportVmCommand] (default task-27) [] Exception: javax.ejb.EJBTransactionRolledbackException: Coding error, pool for requested GUID does not exist
        at org.jboss.as.ejb3.tx.CMTTxInterceptor.handleInCallerTx(CMTTxInterceptor.java:159) [wildfly-ejb3-7.0.1.GA-redhat-2.jar:7.0.1.GA-redhat-2]
        at org.jboss.as.ejb3.tx.CMTTxInterceptor.invokeInCallerTx(CMTTxInterceptor.java:256) [wildfly-ejb3-7.0.1.GA-redhat-2.jar:7.0.1.GA-redhat-2]
        at org.jboss.as.ejb3.tx.CMTTxInterceptor.required(CMTTxInterceptor.java:329) [wildfly-ejb3-7.0.1.GA-redhat-2.jar:7.0.1.GA-redhat-2]
        at org.jboss.as.ejb3.tx.CMTTxInterceptor.processInvocation(CMTTxInterceptor.java:239) [wildfly-ejb3-7.0.1.GA-redhat-2.jar:7.0.1.GA-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)




Caused by: java.lang.IllegalStateException: Coding error, pool for requested GUID does not exist
        at org.ovirt.engine.core.bll.network.macpool.MacPoolPerDc.getMacPoolWithoutLocking(MacPoolPerDc.java:117) [bll.jar:]
        at org.ovirt.engine.core.bll.network.macpool.MacPoolPerDc.getMacPoolById(MacPoolPerDc.java:100) [bll.jar:]
        at org.ovirt.engine.core.bll.network.macpool.MacPoolPerDc.getMacPoolById(MacPoolPerDc.java:105) [bll.jar:]
        at org.ovirt.engine.core.bll.network.macpool.MacPoolPerDc.getMacPoolForDataCenter(MacPoolPerDc.java:87) [bll.jar:]
        at sun.reflect.GeneratedMethodAccessor591.invoke(Unknown Source) [:1.8.0_101]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_101]
        at java.lang.reflect.Method.invoke(Method.java:498) [rt.jar:1.8.0_101]
        at org.jboss.as.ee.component.ManagedReferenceMethodInterceptor.processInvocation(ManagedReferenceMethodInterceptor.java:52)
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)
        at org.jboss.invocation.InterceptorContext$Invocation.proceed(InterceptorContext.java:437)

Comment 1 Nikolai Sednev 2016-07-26 16:01:17 UTC
I'm hitting the same problem also while importing VM from EXPORT domain using WEBUI.
Attaching all logs from my environment.

2016-07-26 11:35:53,012 ERROR [org.jboss.as.ejb3.invocation] (org.ovirt.thread.pool-6-thread-22) WFLYEJB0034: EJB Invocation failed on component M
acPoolPerDc for method public org.ovirt.engine.core.bll.network.macpool.MacPool org.ovirt.engine.core.bll.network.macpool.MacPoolPerDc.getMacPoolF
orDataCenter(org.ovirt.engine.core.compat.Guid,org.ovirt.engine.core.bll.context.CommandContext): javax.ejb.EJBTransactionRolledbackException: Cod
ing error, pool for requested GUID does not exist
        at org.jboss.as.ejb3.tx.CMTTxInterceptor.handleInCallerTx(CMTTxInterceptor.java:159) [wildfly-ejb3-7.0.1.GA-redhat-2.jar:7.0.1.GA-redhat-2
]
        at org.jboss.as.ejb3.tx.CMTTxInterceptor.invokeInCallerTx(CMTTxInterceptor.java:256) [wildfly-ejb3-7.0.1.GA-redhat-2.jar:7.0.1.GA-redhat-2
]
        at org.jboss.as.ejb3.tx.CMTTxInterceptor.required(CMTTxInterceptor.java:329) [wildfly-ejb3-7.0.1.GA-redhat-2.jar:7.0.1.GA-redhat-2]
        at org.jboss.as.ejb3.tx.CMTTxInterceptor.processInvocation(CMTTxInterceptor.java:239) [wildfly-ejb3-7.0.1.GA-redhat-2.jar:7.0.1.GA-redhat-
2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)
        at org.jboss.as.ejb3.component.interceptors.CurrentInvocationContextInterceptor.processInvocation(CurrentInvocationContextInterceptor.java
:41) [wildfly-ejb3-7.0.1.GA-redhat-2.jar:7.0.1.GA-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)
        at org.jboss.as.ejb3.component.invocationmetrics.WaitTimeInterceptor.processInvocation(WaitTimeInterceptor.java:43) [wildfly-ejb3-7.0.1.GA
-redhat-2.jar:7.0.1.GA-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)
        at org.jboss.as.ejb3.security.SecurityContextInterceptor.processInvocation(SecurityContextInterceptor.java:100) [wildfly-ejb3-7.0.1.GA-red
hat-2.jar:7.0.1.GA-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)
        at org.jboss.invocation.InterceptorContext$Invocation.proceed(InterceptorContext.java:437)
        at org.jboss.as.ejb3.concurrency.ContainerManagedConcurrencyInterceptor.processInvocation(ContainerManagedConcurrencyInterceptor.java:110) [wildfly-ejb3-7.0.1.GA-redhat-2.jar:7.0.1.GA-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)
        at org.jboss.as.ejb3.component.interceptors.ShutDownInterceptorFactory$1.processInvocation(ShutDownInterceptorFactory.java:64) [wildfly-ejb3-7.0.1.GA-redhat-2.jar:7.0.1.GA-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)
        at org.jboss.as.ejb3.component.interceptors.LoggingInterceptor.processInvocation(LoggingInterceptor.java:66) [wildfly-ejb3-7.0.1.GA-redhat-2.jar:7.0.1.GA-redhat-2]
        at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)
:

Comment 2 Nikolai Sednev 2016-07-26 16:04:14 UTC
Engine dropped this error only for VM being imported, but not for the imported template.

	
Jul 26, 2016 6:47:25 PM

Failed to import Vm windows7 to Data Center Default, Cluster Default

	
Jul 26, 2016 6:35:53 PM

Failed to import Vm windows7 to Data Center Default, Cluster Default

Comment 3 Nikolai Sednev 2016-07-26 16:06:08 UTC
Created attachment 1184323 [details]
sosreport from the engine

Comment 4 Nikolai Sednev 2016-07-26 16:16:34 UTC
Here goes the host's sosreport link https://drive.google.com/open?id=0B85BEaDBcF88ZGRURjZVc0RHdmM

Comment 5 Michal Skrivanek 2016-07-27 05:06:04 UTC
This is causing the same issue for all import flows

Comment 6 Michal Skrivanek 2016-07-27 05:06:19 UTC
*** Bug 1360321 has been marked as a duplicate of this bug. ***

Comment 7 Michal Skrivanek 2016-07-27 05:06:55 UTC
*** Bug 1360376 has been marked as a duplicate of this bug. ***

Comment 8 Yaniv Lavi 2016-07-28 12:47:03 UTC
Should this be on QA?

Comment 9 Raz Tamir 2016-07-28 12:50:36 UTC
I tested a fix with a jar provided by Yevgeny, but this fix is not included in the latest build

Comment 10 Eyal Edri 2016-07-31 09:09:00 UTC
Yes, its in the latest tag and build:
https://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=shortlog;h=refs/tags/ovirt-engine-4.0.2.2

Anton - can you check why the release script didn't move it to ON_QA?

Comment 11 Nikolai Sednev 2016-07-31 11:14:56 UTC
Works for me via WEBUI on these components on engine:
ovirt-engine-lib-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-setup-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-tools-4.0.2.2-0.1.el7ev.noarch
ovirt-iso-uploader-4.0.0-1.el7ev.noarch
ovirt-engine-setup-plugin-ovirt-engine-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-webadmin-portal-debuginfo-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-dbscripts-4.0.2.2-0.1.el7ev.noarch
ovirt-vmconsole-proxy-1.0.4-1.el7ev.noarch
ovirt-engine-dwh-setup-4.0.2-1.el7ev.noarch
ovirt-engine-dwh-4.0.2-1.el7ev.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-websocket-proxy-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-webadmin-portal-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-cli-3.6.7.0-1.el7ev.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
ovirt-setup-lib-1.0.2-1.el7ev.noarch
ovirt-engine-dashboard-1.0.1-0.el7ev.x86_64
ovirt-engine-setup-base-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-setup-plugin-websocket-proxy-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-extensions-api-impl-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-tools-backup-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-backend-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-restapi-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-sdk-python-3.6.7.0-1.el7ev.noarch
ovirt-log-collector-4.0.0-1.el7ev.noarch
ovirt-host-deploy-java-1.5.1-1.el7ev.noarch
ovirt-engine-setup-plugin-vmconsole-proxy-helper-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-userportal-debuginfo-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-4.0.2.2-0.1.el7ev.noarch
python-ovirt-engine-sdk4-4.0.0-0.5.a5.el7ev.x86_64
ovirt-engine-vmconsole-proxy-helper-4.0.2.2-0.1.el7ev.noarch
ovirt-engine-userportal-4.0.2.2-0.1.el7ev.noarch
ovirt-image-uploader-4.0.0-1.el7ev.noarch
ovirt-host-deploy-1.5.1-1.el7ev.noarch
ovirt-engine-extension-aaa-jdbc-1.1.0-1.el7ev.noarch
rhev-guest-tools-iso-4.0-5.el7ev.noarch
rhevm-setup-plugins-4.0.0.2-1.el7ev.noarch
rhevm-4.0.2.2-0.1.el7ev.noarch
rhevm-doc-4.0.0-3.el7ev.noarch
rhevm-branding-rhev-4.0.0-3.el7ev.noarch
rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
rhevm-spice-client-x64-msi-4.0-3.el7ev.noarch
rhevm-spice-client-x86-msi-4.0-3.el7ev.noarch
rhevm-dependencies-4.0.0-1.el7ev.noarch
rhev-release-4.0.2-4-001.noarch
rhev-release-4.0.1-2-001.noarch
Linux version 3.10.0-327.22.2.el7.x86_64 (mockbuild@x86-030.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Thu Jun 9 10:09:10 EDT 2016
Linux 3.10.0-327.22.2.el7.x86_64 #1 SMP Thu Jun 9 10:09:10 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.2 (Maipo)

On host:
qemu-kvm-rhev-2.3.0-31.el7_2.20.x86_64
ovirt-imageio-daemon-0.3.0-0.el7ev.noarch
libvirt-client-1.2.17-13.el7_2.5.x86_64
ovirt-vmconsole-1.0.4-1.el7ev.noarch
rhev-release-4.0.2-4-001.noarch
vdsm-4.18.9-1.el7ev.x86_64
ovirt-host-deploy-1.5.1-1.el7ev.noarch
ovirt-hosted-engine-ha-2.0.1-1.el7ev.noarch
ovirt-hosted-engine-setup-2.0.1.3-1.el7ev.noarch
ovirt-engine-sdk-python-3.6.7.0-1.el7ev.noarch
mom-0.5.5-1.el7ev.noarch
ovirt-setup-lib-1.0.2-1.el7ev.noarch
ovirt-imageio-common-0.3.0-0.el7ev.noarch
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
sanlock-3.2.4-3.el7_2.x86_64
Linux version 3.10.0-327.30.1.el7.x86_64 (mockbuild@x86-039.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Wed Jul 13 22:09:46 EDT 2016
Linux 3.10.0-327.30.1.el7.x86_64 #1 SMP Wed Jul 13 22:09:46 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.2 (Maipo)

VM was successfully imported from export domain.

Comment 12 Raz Tamir 2016-07-31 11:17:20 UTC
Thanks Nikolai,
According to last comment, moving to verify.


Note You need to log in before you can comment on or make changes to this bug.