Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359667 - [Virtual Machines] [UI] - Can't import vm from export domain, engine report that there is no active export domain, although there is
Summary: [Virtual Machines] [UI] - Can't import vm from export domain, engine report t...
Keywords:
Status: CLOSED DUPLICATE of bug 1340025
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.0.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ovirt-4.0.2
: ---
Assignee: Michal Skrivanek
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-25 09:20 UTC by Michael Burman
Modified: 2016-07-28 08:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-28 07:58:58 UTC
oVirt Team: Virt
gklein: ovirt-4.0.z?
gklein: blocker?
mgoldboi: planning_ack+
mburman: devel_ack?
mburman: testing_ack?


Attachments (Terms of Use)
screenshot1 (deleted)
2016-07-25 11:01 UTC, Michael Burman
no flags Details
screenshot2 (deleted)
2016-07-25 11:01 UTC, Michael Burman
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1359668 None None None Never

Internal Links: 1359668

Description Michael Burman 2016-07-25 09:20:05 UTC
Description of problem:
Can't import vm from export domain, engine report that there is no active export domain, although there is.

- Via the Virtual Machines main tab > 'Import' - engine report there is no active export domain although there is an active one in the setup. 

- Via the 'Storage' main tab > 'Import' from export domain, i can see the vm and import it with success. 

 
Version-Release number of selected component (if applicable):
4.0.2-0.1.rc.el7ev

How reproducible:
100

Steps to Reproduce:
1. Try to import vm from export domain via the 'Virtual Machines' main tab

Actual results:
Can't import vm because engine report there is no active storage domain in the setup.

Expected results:
Should work as expected.

Comment 1 Michael Burman 2016-07-25 09:25:57 UTC
If we will switch the source to VMware for example and then back to Export Domain, we will see that the 'Load' button is no longer grayed out and we will be able to load and import the vm.

Comment 2 Michal Skrivanek 2016-07-25 10:44:05 UTC
duplicate of bug 1354495?

Comment 3 Michael Burman 2016-07-25 11:00:20 UTC
No.

The bug is that you don't have any active export domain although you have. 
Comment 1^^, is just a work around.

Comment 4 Michael Burman 2016-07-25 11:01:21 UTC
Created attachment 1183738 [details]
screenshot1

Comment 5 Michael Burman 2016-07-25 11:01:56 UTC
Created attachment 1183740 [details]
screenshot2

Comment 6 Michal Skrivanek 2016-07-25 11:26:54 UTC
sorry, i've meant a different bug - it is duplicate of bug 1340025
Since when this is a regression?

Comment 7 Michael Burman 2016-07-25 11:35:12 UTC
(In reply to Michal Skrivanek from comment #6)
> sorry, i've meant a different bug - it is duplicate of bug 1340025
> Since when this is a regression?

I guess that yes, seems like it's the same. 
I don't know since when, but this is defiantly worked on previous versions. 

And btw, i see that this bug is appears to be on 3.6.8.1-0.1.el6 as well.

Comment 8 Michal Skrivanek 2016-07-25 12:08:07 UTC
(In reply to Michael Burman from comment #7)
> (In reply to Michal Skrivanek from comment #6)
> > sorry, i've meant a different bug - it is duplicate of bug 1340025
> > Since when this is a regression?
> 
> I guess that yes, seems like it's the same. 
> I don't know since when, but this is defiantly worked on previous versions. 
> 
> And btw, i see that this bug is appears to be on 3.6.8.1-0.1.el6 as well.

yes, and i reproduced it in 3.6.7 as well, hence I'm asking since when this is a regression, because it seems to me it's not. I suggest to drop the Regression kw and not block 4.0

Comment 9 Michael Burman 2016-07-25 13:10:33 UTC
I really don't know since when, i'm not testing this on daily basis, but it worked for sure on previous versions, so i guess it is a regression, but no idea since when. 

About blocking 4.0 maybe you are right, but it's not me to decide..)

Yaniv, Gil ?

Comment 10 Michal Skrivanek 2016-07-28 07:58:58 UTC
- removing Regression as this is not a regression
- moving to 4.0.4 due to a risk for 4.0.2, adjusting bug 1340025 accordingly

*** This bug has been marked as a duplicate of bug 1340025 ***


Note You need to log in before you can comment on or make changes to this bug.