Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359534 - [packaging] [debuginfo] java-1.8.0-openjdk-debuginfo installs many files twice
Summary: [packaging] [debuginfo] java-1.8.0-openjdk-debuginfo installs many files twice
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-24 18:57 UTC by Christian Stadelmann
Modified: 2016-07-25 12:33 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-25 12:01:40 UTC


Attachments (Terms of Use)

Description Christian Stadelmann 2016-07-24 18:57:28 UTC
Description of problem:
The debuginfo package for java-1.8.0-openjdk installs all binary files to both /usr/lib/debug/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.92-5.b14.fc24.x86_64-debug and /usr/lib/debug/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.92-5.b14.fc24.x86_64

Version-Release number of selected component (if applicable):
java-1.8.0-openjdk-debuginfo-1.8.0.92-5.b14.fc24.x86_64

How reproducible:
always, 

Steps to Reproduce:
1. install java-1.8.0-openjdk-debuginfo, e.g. by running `dnf debuginfo-install java-1.8.0-openjdk`
2. have a look at disk space consumption

Actual results:
Both folders have very similar content. Filenames are exactly the same.

Expected results:
If you need these files to be present in two directories, please use symlinks instead of copying the files

Additional info:
This results in unnecessary package and disk size.

Comment 1 Andrew John Hughes 2016-07-25 03:03:31 UTC
(In reply to Christian Stadelmann from comment #0)
> Description of problem:
> The debuginfo package for java-1.8.0-openjdk installs all binary files to
> both
> /usr/lib/debug/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.92-5.b14.fc24.x86_64-
> debug and
> /usr/lib/debug/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.92-5.b14.fc24.x86_64
> 
> Version-Release number of selected component (if applicable):
> java-1.8.0-openjdk-debuginfo-1.8.0.92-5.b14.fc24.x86_64
> 
> How reproducible:
> always, 
> 
> Steps to Reproduce:
> 1. install java-1.8.0-openjdk-debuginfo, e.g. by running `dnf
> debuginfo-install java-1.8.0-openjdk`

Does this install any other packages?

It looks like you're ended up with debuginfo for both the production and debug builds of OpenJDK.

> 2. have a look at disk space consumption
> 
> Actual results:
> Both folders have very similar content. Filenames are exactly the same.
> 

But are the files identical?

You could say the same thing about java-1.7.0-openjdk and java-1.8.0-openjdk; both have a very similar layout and files, but the content is different.

> Expected results:
> If you need these files to be present in two directories, please use
> symlinks instead of copying the files
> 
> Additional info:
> This results in unnecessary package and disk size.

Comment 2 Christian Stadelmann 2016-07-25 07:05:05 UTC
(In reply to Andrew John Hughes from comment #1)
> (In reply to Christian Stadelmann from comment #0)
> > Steps to Reproduce:
> > 1. install java-1.8.0-openjdk-debuginfo, e.g. by running `dnf
> > debuginfo-install java-1.8.0-openjdk`
> 
> Does this install any other packages?

No. Just have a look at the RPM you'll be downloading with `dnf download java-1.8.0-openjdk-debuginfo`

> 
> It looks like you're ended up with debuginfo for both the production and
> debug builds of OpenJDK.

Oh, that sounds like the point I didn't get. Since there is just one single debuginfo package for the whole java-1.8.0-openjdk source package, it just contains debuginfo files for both "release" and "debug" libraries.

Would it make sense to split this into two -debuginfo packages?

> But are the files identical?

No, probably due to the reason above.

Comment 3 jiri vanek 2016-07-25 12:01:40 UTC
> > It looks like you're ended up with debuginfo for both the production and
> > debug builds of OpenJDK.
> 
> Oh, that sounds like the point I didn't get. Since there is just one single
> debuginfo package for the whole java-1.8.0-openjdk source package, it just
> contains debuginfo files for both "release" and "debug" libraries.
> 
> Would it make sense to split this into two -debuginfo packages?
> 
> > But are the files identical?
> 
> No, probably due to the reason above.

Yes. thats the case. Unluckily the separation can not be done simply. The debuginfo extraction is fully automated process and any modification will bring enormous overhead to spec file.

Also, alas, I can not build debug subpackages as separate package, as even smallest change  in buildroot will discard the usefulness of debug sub-packages.

Sorry for inconvenience.

Comment 4 Christian Stadelmann 2016-07-25 12:33:29 UTC
Ok. Thanks anyway!


Note You need to log in before you can comment on or make changes to this bug.