Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359504 - UX: exception when clicking on a host's 'Software' subtab
Summary: UX: exception when clicking on a host's 'Software' subtab
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.0.2
Hardware: Unspecified
OS: Unspecified
high
urgent vote
Target Milestone: ovirt-4.0.2
: 4.0.2.1
Assignee: Alexander Wels
QA Contact: Lukas Svaty
URL:
Whiteboard:
: 1359095 1359486 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-24 11:50 UTC by Yaniv Kaul
Modified: 2016-08-12 14:27 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-12 14:27:35 UTC
oVirt Team: UX
rule-engine: ovirt-4.0.z+
rule-engine: blocker+
mgoldboi: planning_ack+
rule-engine: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 61322 master MERGED webadmin: Fix exception in general->software 2016-07-25 13:48:09 UTC
oVirt gerrit 61329 ovirt-engine-4.0 MERGED webadmin: Fix exception in general->software 2016-07-25 14:23:03 UTC
oVirt gerrit 61335 ovirt-engine-4.0.2 MERGED webadmin: Fix exception in general->software 2016-07-25 14:26:03 UTC

Description Yaniv Kaul 2016-07-24 11:50:55 UTC
Description of problem:
When I click on the 'software' sub-tab under general, I get an exception:
2016-07-24 07:48:12,435 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-9) [] Permutation name: D8C04517405A1906726C39BE47E8C13C
2016-07-24 07:48:12,435 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-9) [] Uncaught exception: : java.lang.IndexOutOfBoundsException
        at java.lang.Throwable.fillInStackTrace(Throwable.java:114) [rt.jar:1.8.0_101]
        at java.lang.Exception.Exception(Exception.java:25) [rt.jar:1.8.0_101]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:25) [rt.jar:1.8.0_101]
        at java.lang.IndexOutOfBoundsException.IndexOutOfBoundsException(IndexOutOfBoundsException.java:25) [rt.jar:1.8.0_101]
        at com.google.gwt.user.client.ui.WidgetCollection.$get(WidgetCollection.java:110) [gwt-servlet.jar:]
        at com.google.gwt.user.client.ui.ComplexPanel.$getWidget(ComplexPanel.java:35) [gwt-servlet.jar:]
        at org.ovirt.engine.ui.common.widget.form.AbstractFormPanel.$findColumn(AbstractFormPanel.java:135)
        at org.ovirt.engine.ui.common.widget.form.AbstractFormPanel.$addFormItem(AbstractFormPanel.java:100)
        at org.ovirt.engine.ui.common.widget.form.FormBuilder.$addFormItem(FormBuilder.java:50)
        at org.ovirt.engine.ui.webadmin.section.main.view.tab.host.SubTabHostGeneralSoftwareView.SubTabHostGeneralSoftwareView(SubTabHostGeneralSoftwareView.java:64)
        at org.ovirt.engine.ui.webadmin.section.main.view.tab.host.com_gwtplatform_mvp_client_DesktopGinjector_DesktopGinjectorGinjector_fragment.$get_Key$type$org$ovirt$engine$ui$webadmin$section$main$view$tab$host$SubTabHostGeneralSoftwareView$_annotation$$none$$(com_gwtplatform_mvp_client_DesktopGinjector_DesktopGinjectorGinjector_fragment.java:103)
        at org.ovirt.engine.ui.webadmin.section.main.presenter.tab.host.com_gwtplatform_mvp_client_DesktopGinjector_DesktopGinjectorGinjector_fragment.$get_Key$type$org$ovirt$engine$ui$webadmin$section$main$presenter$tab$host$SubTabHostGeneralSoftwarePresenter$_annotation$$none$$(com_gwtplatform_mvp_client_DesktopGinjector_DesktopGinjectorGinjector_fragment.java:829)
        at org.ovirt.engine.ui.webadmin.section.main.presenter.tab.host.com_gwtplatform_mvp_client_DesktopGinjector_DesktopGinjectorGinjector_fragment$9$1.onSuccess(com_gwtplatform_mvp_client_DesktopGinjector_DesktopGinjectorGinjector_fragment.java:854)
        at com.google.gwt.core.client.impl.AsyncFragmentLoader.$onLoadImpl(AsyncFragmentLoader.java:569) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.AsyncFragmentLoader.onLoad(AsyncFragmentLoader.java:275) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
        at Unknown.Ux/<(Unknown Source)
        at Unknown.anonymous(Unknown Source)
        at Unknown.webadmin/webadmin.__installRunAsyncCode(Unknown Source)
        at Unknown.__gwtInstallCode(Unknown Source)
        at com.google.gwt.core.client.impl.LoadingStrategyBase$RequestData.$tryInstall(LoadingStrategyBase.java:138) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.ScriptTagLoadingStrategy.asyncCallback(ScriptTagLoadingStrategy.java:56) [gwt-servlet.jar:]
        at Unknown.anonymous(Unknown Source)
        at com.google.gwt.core.client.impl.Impl.apply(Impl.java:296) [gwt-servlet.jar:]
        at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:335) [gwt-servlet.jar:]
        at Unknown.Ux/<(Unknown Source)
        at Unknown.anonymous(Unknown Source)
        at Unknown.anonymous(Unknown Source)


The others (HW, errata) seem to be fine.

This is when running in Lago.
running in FF 47.0 on Fedora 23.

Version-Release number of selected component (if applicable):
ovirt-engine-cli-3.6.8.1-1.el7.centos.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-engine-webadmin-portal-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-engine-setup-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-engine-backend-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-host-deploy-1.5.2-0.0.master.20160712140220.git9e77e0e.el7.centos.noarch
ovirt-engine-wildfly-overlay-10.0.0-1.el7.noarch
ovirt-setup-lib-1.0.2-1.el7.centos.noarch
ovirt-engine-extension-aaa-ldap-1.2.2-0.0.master.20160629222654.git2afbeb2.el7.noarch
ovirt-engine-webadmin-portal-debuginfo-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-engine-extension-aaa-jdbc-1.1.1-0.0.master.20160526092913.git2e68ef6.el7.noarch
ovirt-vmconsole-1.0.4-0.0.master.20160711122950.gitf23ff5d.el7.noarch
ovirt-engine-tools-backup-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-engine-websocket-proxy-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-host-deploy-java-1.5.2-0.0.master.20160712140220.git9e77e0e.el7.centos.noarch
ovirt-engine-dwh-4.1.0-0.0.master.20160706082926.el7.centos.noarch
ovirt-engine-dashboard-1.1.0-0.1.20160722git80f6c63.el7.centos.noarch
ovirt-engine-userportal-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-engine-setup-plugin-vmconsole-proxy-helper-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-engine-setup-plugin-ovirt-engine-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-engine-tools-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-engine-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
python-ovirt-engine-sdk4-4.0.0-0.3.a3.el7.centos.x86_64
ovirt-iso-uploader-4.0.1-0.0.master.20160531154203.git7213b00.el7.centos.noarch
ovirt-engine-wildfly-10.0.0-1.el7.x86_64
ovirt-engine-lib-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-vmconsole-proxy-1.0.4-0.0.master.20160711122950.gitf23ff5d.el7.noarch
ovirt-engine-setup-plugin-websocket-proxy-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-engine-dwh-setup-4.1.0-0.0.master.20160706082926.el7.centos.noarch
ovirt-engine-dbscripts-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-engine-vmconsole-proxy-helper-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-engine-restapi-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-engine-extension-aaa-ldap-setup-1.2.2-0.0.master.20160629222654.git2afbeb2.el7.noarch
ovirt-engine-sdk-python-3.6.8.0-1.el7.centos.noarch
ovirt-engine-extensions-api-impl-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch
ovirt-image-uploader-4.0.1-0.0.master.20160601214601.gitd6fd324.el7.centos.noarch
ovirt-engine-setup-base-4.1.0-0.0.master.20160723231313.gite5294ab.el7.centos.noarch


How reproducible:
Always in this setup.

Comment 1 Yaniv Kaul 2016-07-24 12:29:58 UTC
This also happens on 4.0.2, and on real setup (above was on Lago) - raising severity.

Comment 2 Yaniv Kaul 2016-07-24 12:30:05 UTC
*** Bug 1359486 has been marked as a duplicate of this bug. ***

Comment 3 Yaniv Kaul 2016-07-25 09:04:44 UTC
*** Bug 1359483 has been marked as a duplicate of this bug. ***

Comment 4 Red Hat Bugzilla Rules Engine 2016-07-25 10:34:12 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 5 Oved Ourfali 2016-07-25 12:06:32 UTC
Alexander, can you take a look?

Comment 6 Oved Ourfali 2016-07-25 13:49:24 UTC
Still requires 4.0 and 4.0.2 backports.

Comment 7 Oved Ourfali 2016-07-27 08:38:15 UTC
Sandro - should it move to ON_QA?

Comment 8 Nikolai Sednev 2016-07-28 07:29:26 UTC
I'm getting correctly data from "Software" sub-tub.


Works for me on these components:
Engine:
ovirt-engine-setup-plugin-ovirt-engine-common-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-websocket-proxy-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-userportal-4.0.2.1-0.1.el7ev.noarch
ovirt-iso-uploader-4.0.0-1.el7ev.noarch
ovirt-engine-setup-plugin-vmconsole-proxy-helper-4.0.2.1-0.1.el7ev.noarch
ovirt-vmconsole-proxy-1.0.4-1.el7ev.noarch
ovirt-engine-dwh-setup-4.0.2-1.el7ev.noarch
ovirt-engine-webadmin-portal-debuginfo-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-backend-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-dwh-4.0.2-1.el7ev.noarch
ovirt-engine-cli-3.6.7.0-1.el7ev.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
ovirt-setup-lib-1.0.2-1.el7ev.noarch
ovirt-engine-dashboard-1.0.1-0.el7ev.x86_64
ovirt-engine-setup-plugin-websocket-proxy-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-setup-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-extensions-api-impl-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-userportal-debuginfo-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-webadmin-portal-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-dbscripts-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-restapi-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-sdk-python-3.6.7.0-1.el7ev.noarch
ovirt-log-collector-4.0.0-1.el7ev.noarch
ovirt-host-deploy-java-1.5.1-1.el7ev.noarch
ovirt-engine-lib-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-setup-plugin-ovirt-engine-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-tools-backup-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-4.0.2.1-0.1.el7ev.noarch
python-ovirt-engine-sdk4-4.0.0-0.5.a5.el7ev.x86_64
ovirt-engine-setup-base-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-vmconsole-proxy-helper-4.0.2.1-0.1.el7ev.noarch
ovirt-engine-tools-4.0.2.1-0.1.el7ev.noarch
ovirt-image-uploader-4.0.0-1.el7ev.noarch
ovirt-host-deploy-1.5.1-1.el7ev.noarch
ovirt-engine-extension-aaa-jdbc-1.1.0-1.el7ev.noarch
rhev-guest-tools-iso-4.0-5.el7ev.noarch
rhev-release-4.0.2-3-001.noarch
rhevm-4.0.2.1-0.1.el7ev.noarch
rhevm-setup-plugins-4.0.0.2-1.el7ev.noarch
rhevm-doc-4.0.0-3.el7ev.noarch
rhevm-branding-rhev-4.0.0-3.el7ev.noarch
rhevm-guest-agent-common-1.0.12-3.el7ev.noarch
rhevm-spice-client-x64-msi-4.0-3.el7ev.noarch
rhevm-spice-client-x86-msi-4.0-3.el7ev.noarch
rhevm-dependencies-4.0.0-1.el7ev.noarch
rhev-release-4.0.1-2-001.noarch
Linux version 3.10.0-327.22.2.el7.x86_64 (mockbuild@x86-030.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Thu Jun 9 10:09:10 EDT 2016
Linux 3.10.0-327.22.2.el7.x86_64 #1 SMP Thu Jun 9 10:09:10 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.2 (Maipo)


Host:
ovirt-imageio-daemon-0.3.0-0.el7ev.noarch
libvirt-client-1.2.17-13.el7_2.5.x86_64
ovirt-vmconsole-1.0.4-1.el7ev.noarch
vdsm-4.18.9-1.el7ev.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.19.x86_64
ovirt-host-deploy-1.5.1-1.el7ev.noarch
ovirt-hosted-engine-ha-2.0.1-1.el7ev.noarch
ovirt-hosted-engine-setup-2.0.1.3-1.el7ev.noarch
ovirt-engine-sdk-python-3.6.7.0-1.el7ev.noarch
mom-0.5.5-1.el7ev.noarch
ovirt-setup-lib-1.0.2-1.el7ev.noarch
ovirt-imageio-common-0.3.0-0.el7ev.noarch
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
rhev-release-4.0.2-3-001.noarch
sanlock-3.2.4-3.el7_2.x86_64
Linux version 3.10.0-327.30.1.el7.x86_64 (mockbuild@x86-039.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Wed Jul 13 22:09:46 EDT 2016
Linux 3.10.0-327.30.1.el7.x86_64 #1 SMP Wed Jul 13 22:09:46 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.2 (Maipo)

Comment 9 Oved Ourfali 2016-08-01 12:02:19 UTC
*** Bug 1359095 has been marked as a duplicate of this bug. ***

Comment 10 Lukas Svaty 2016-08-02 06:42:14 UTC
verified in ovirt-engine-webadmin-portal-4.0.2.3-0.1.el7ev.noarch


Note You need to log in before you can comment on or make changes to this bug.