Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359492 - Occasionally crashes with applet_get_first_active_vpn_connection: assertion failed: (s_con) error
Summary: Occasionally crashes with applet_get_first_active_vpn_connection: assertion ...
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: network-manager-applet
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1368902 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-24 09:05 UTC by Tore Anderson
Modified: 2017-08-08 15:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-08 15:50:27 UTC


Attachments (Terms of Use)
/var/spool/abrt/ccpp-2016-07-12-05:11:28-1558/core_backtrace (deleted)
2016-07-24 09:05 UTC, Tore Anderson
no flags Details
[PATCH] applet: fix an assertion error (deleted)
2016-08-17 12:56 UTC, Blueowl
no flags Details | Diff

Description Tore Anderson 2016-07-24 09:05:15 UTC
Created attachment 1183324 [details]
/var/spool/abrt/ccpp-2016-07-12-05:11:28-1558/core_backtrace

Description of problem:

nm-applet occasionally crashes. When this happens the following error message is logged to ~/.cache/lxsession/LXDE/run.log:

nm-applet:ERROR:applet.c:1095:applet_get_first_active_vpn_connection: assertion failed: (s_con)

Version-Release number of selected component (if applicable):

network-manager-applet-1.2.0-1.fc24.x86_64

How reproducible:

I do not know how to reproduce it. It happens occasionally. I think I might need to have an active VPN connection for it to occur.

Additional info:

The crash gets picked up by ABRT, but the retracing job fails with "eu-unstrip: No modules recognized in core file". This prevents me from submitting a fully retraced bug report via ABRT.

I'm attaching the "core_backtrace" file from the ABRT crash directory though, as it seems to me that it might contain interesting information. If you want I can upload an archive containing the entire directory too, just let me know.

Comment 1 Blueowl 2016-07-24 11:57:19 UTC
I've found a reproducer:
* switch an active connection to be available only for not logged (non-existent) user
1) sudo sh -c "echo 'USERS=cimrman' >>  /etc/sysconfig/network-scripts/ifcfg-HomeWifi"
2) sudo nmcli con load /etc/sysconfig/network-scripts/ifcfg-HomeWifi

Thread 1 "nm-applet" received signal SIGABRT, Aborted.
0x00007ffff3fcd6f5 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
54	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
Missing separate debuginfos, use: dnf debuginfo-install GConf2-3.2.6-16.fc24.x86_64 ModemManager-glib-1.6-0.3.rc3.fc24.x86_64 at-spi2-atk-2.20.1-1.fc24.x86_64 at-spi2-core-2.20.2-1.fc24.x86_64 dconf-0.26.0-1.fc24.x86_64 expat-2.1.1-2.fc24.x86_64 fontconfig-2.11.94-6.fc24.x86_64 freetype-2.6.3-2.fc24.x86_64 gdk-pixbuf2-2.34.0-1.fc24.x86_64 graphite2-1.3.6-1.fc24.x86_64 gvfs-client-1.28.2-1.fc24.x86_64 harfbuzz-1.2.7-1.fc24.x86_64 libX11-1.6.3-3.fc24.x86_64 libXau-1.0.8-6.fc24.x86_64 libXcomposite-0.4.4-8.fc24.x86_64 libXcursor-1.1.14-6.fc24.x86_64 libXdamage-1.1.4-8.fc24.x86_64 libXext-1.3.3-4.fc24.x86_64 libXfixes-5.0.2-2.fc24.x86_64 libXi-1.7.6-2.fc24.x86_64 libXinerama-1.1.3-6.fc24.x86_64 libXrandr-1.5.0-3.fc24.x86_64 libXrender-0.9.9-3.fc24.x86_64 libXxf86vm-1.1.4-3.fc24.x86_64 libattr-2.4.47-16.fc24.x86_64 libcap-2.24-9.fc24.x86_64 libdatrie-0.2.9-3.fc24.x86_64 libdrm-2.4.68-1.fc24.x86_64 libepoxy-1.3.1-2.fc24.x86_64 libgudev-230-3.fc24.x86_64 libnotify-0.7.6-8.fc24.x86_64 libpng-1.6.23-1.fc24.x86_64 libsecret-0.18.5-1.fc24.x86_64 libthai-0.1.24-1.fc24.x86_64 libwayland-client-1.10.0-1.fc24.x86_64 libwayland-cursor-1.10.0-1.fc24.x86_64 libwayland-server-1.10.0-1.fc24.x86_64 libxcb-1.11.1-2.fc24.x86_64 libxkbcommon-0.6.1-1.fc24.x86_64 libxshmfence-1.2-3.fc24.x86_64 lz4-r131-2.fc24.x86_64 mesa-libEGL-12.0.1-1.fc24.x86_64 mesa-libGL-12.0.1-1.fc24.x86_64 mesa-libgbm-12.0.1-1.fc24.x86_64 mesa-libglapi-12.0.1-1.fc24.x86_64 mesa-libwayland-egl-12.0.1-1.fc24.x86_64 pixman-0.34.0-2.fc24.x86_64
(gdb) bt
#0  0x00007ffff3fcd6f5 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
#1  0x00007ffff3fcf2fa in __GI_abort () at abort.c:89
#2  0x00007ffff47fcf05 in g_assertion_message (domain=domain@entry=0x5555555870af "nm-applet", file=file@entry=0x555555586ebc "applet.c", line=line@entry=1095, func=func@entry=0x555555588720 <__FUNCTION__.69158> "applet_get_first_active_vpn_connection", message=message@entry=0x5555559847a0 "assertion failed: (s_con)") at gtestutils.c:2429
#3  0x00007ffff47fcf9a in g_assertion_message_expr (domain=domain@entry=0x5555555870af "nm-applet", file=file@entry=0x555555586ebc "applet.c", line=line@entry=1095, func=func@entry=0x555555588720 <__FUNCTION__.69158> "applet_get_first_active_vpn_connection", expr=expr@entry=0x555555586eb6 "s_con")
    at gtestutils.c:2452
#4  0x00005555555655fe in applet_get_first_active_vpn_connection (applet=applet@entry=0x5555558160c0 [NMApplet], out_state=out_state@entry=0x7fffffffdd14)
    at applet.c:1095
#5  0x000055555556b3c2 in applet_update_icon (user_data=<optimized out>) at applet.c:2631
#6  0x00007ffff47d7703 in g_main_context_dispatch (context=0x5555557de340) at gmain.c:3154
#7  0x00007ffff47d7703 in g_main_context_dispatch (context=context@entry=0x5555557de340) at gmain.c:3769
#8  0x00007ffff47d7ab0 in g_main_context_iterate (context=context@entry=0x5555557de340, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>)
    at gmain.c:3840
#9  0x00007ffff47d7b5c in g_main_context_iteration (context=context@entry=0x5555557de340, may_block=may_block@entry=1) at gmain.c:3901
#10 0x00007ffff4f9e58d in g_application_run (application=0x5555558160c0 [NMApplet], argc=1, argv=0x7fffffffdf00) at gapplication.c:2381
#11 0x0000555555564aa0 in main (argc=<optimized out>, argv=<optimized out>) at main.c:81
(gdb) 

It's been fixed upstream.
https://git.gnome.org/browse/network-manager-applet/commit/?id=c3255ed740592a2f23a7ebc47f1acd2dd2d768b3

Comment 2 Tore Anderson 2016-07-24 13:25:10 UTC
Thanks for the analysis. Reading those links I too found a sure way to reproduce:

1) Ensure computer/NM is connected, e.g., using a wired ethernet cable
2) Start nm-applet
3) Connect VPN using nm-applet menu
4) Press the already-connected wired ethernet connection (to make it reconnect)

It instantly asserts and crashes.

I upgraded to network-manager-applet-1.2.2-1.fc25.x86_64 from rawhide, no improvements there. So a backport would be nice.

Comment 3 Blueowl 2016-08-17 12:52:44 UTC
The crash is fixed in network-manager-applet-1.2.4-1.fc24 [1].

However, I can see this error in a terminal when running comment #1 test:
libnm-CRITICAL **: nm_setting_connection_get_id: assertion 'NM_IS_SETTING_CONNECTION (setting)' failed

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=788337

Comment 4 Blueowl 2016-08-17 12:56:02 UTC
Created attachment 1191626 [details]
[PATCH] applet: fix an assertion error

Fix an assertion error mentioned in the previous comment.

Comment 5 Thomas Haller 2016-08-17 19:46:27 UTC
(In reply to Blueowl from comment #4)
> Created attachment 1191626 [details]
> [PATCH] applet: fix an assertion error
> 
> Fix an assertion error mentioned in the previous comment.

this is strange... 

with commits https://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=23136ecf89f279479337ead355b7ff5e8046 (part of 1.2.0+), libnm/libnm-glib should properly expose any (possibly invalid) connection to the library user.
As such, I would always expect that every connection has a valid ID. How could that possibly fail? Sounds like a bug in libnm.

Might be worth to investigate more...


(In reply to Tore Anderson from comment #2)
> I upgraded to network-manager-applet-1.2.2-1.fc25.x86_64 from rawhide, no
> improvements there. So a backport would be nice.

1.2.2 didn't yet have the mentioned fix (c3255ed740592a2f23a7ebc47f1acd2dd2d768b3), while 1.2.4 has the backport. So, that sounds plausible.

Comment 6 Fedora Update System 2016-08-19 10:34:42 UTC
network-manager-applet-1.2.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f739ece3cf

Comment 7 Fedora Update System 2016-08-19 23:21:54 UTC
network-manager-applet-1.2.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f739ece3cf

Comment 8 Fedora Update System 2016-08-21 12:40:00 UTC
network-manager-applet-1.2.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f739ece3cf

Comment 9 Fedora Update System 2016-08-21 20:51:34 UTC
network-manager-applet-1.2.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f739ece3cf

Comment 10 Blueowl 2016-08-22 19:26:48 UTC
*** Bug 1368902 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2016-08-27 15:19:26 UTC
network-manager-applet-1.2.4-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora End Of Life 2017-07-25 22:00:46 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 13 Fedora End Of Life 2017-08-08 15:50:27 UTC
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.