Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359391 - Hercules Studio package produces weird output. re-building creates a normal product
Summary: Hercules Studio package produces weird output. re-building creates a normal p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hercstudio
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-23 16:28 UTC by dekel35
Modified: 2016-08-04 20:55 UTC (History)
1 user (show)

Fixed In Version: hercstudio-1.5.0-7.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-04 20:55:13 UTC


Attachments (Terms of Use)
Watch as each line contains artifacts from the longest line so far (deleted)
2016-07-23 16:28 UTC, dekel35
no flags Details

Description dekel35 2016-07-23 16:28:13 UTC
Created attachment 1183139 [details]
Watch as each line contains artifacts from the longest line so far

Description of problem:
Log lines at the main window contain leftovers from previous lines. 
for example:
line1: 123456
line2: 789

the output is:
123456
789456

Version-Release number of selected component (if applicable):
hercstudio 1.5.0


How reproducible:
By installing hercstudio and watching the log lines printed on the main window.
Problem does not heppwn when building the binary from source file on the same installation.

Steps to Reproduce:
1. Install Fedora 24 Workstation
2. Install Hercstudio
3. run HerculeStudio from the command line or invoke from the gui menu
4. Create a minimal configuration file: File/New.../Ok/(name)/Save
5. Press on the "Power On" white button

Actual results:
Each short line contains leftover from the previous long line

Expected results:
Each line contains just the data of that line.

Additional info:
1. When building hercules studio on Fedora 24, this problem does not happen. The problem is only with the package from the Fedora 24 repository. 
2. Further info (with pictures) can be found on Hercules Studio support site:
https://groups.yahoo.com/neo/groups/hercstudio/info

Comment 1 Fedora Update System 2016-07-24 18:43:37 UTC
hercstudio-1.5.0-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1e0de7b752

Comment 2 Fedora Update System 2016-07-28 06:01:35 UTC
hercstudio-1.5.0-7.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1e0de7b752

Comment 3 dekel35 2016-07-29 08:27:47 UTC
In hercstudio-1.5.0-7.fc24.x86_64 the problem is gone.

Comment 4 Fedora Update System 2016-08-04 20:55:11 UTC
hercstudio-1.5.0-7.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.