Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359166 - Missing dependency for pdns-backend-remote
Summary: Missing dependency for pdns-backend-remote
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: pdns
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Morten Stevens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-22 12:40 UTC by Lutz Heermann
Modified: 2016-08-09 14:20 UTC (History)
3 users (show)

Fixed In Version: pdns-3.4.8-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-09 14:20:08 UTC


Attachments (Terms of Use)

Description Lutz Heermann 2016-07-22 12:40:53 UTC
Description of problem:

The PowerDNS remote backend can't be installed any more, because of a missing dependency.

Version-Release number of selected component (if applicable):
3.4.8-2.el7

How reproducible:


Steps to Reproduce:
yum install pdns-backend-remote

Actual results:
Error: Package: pdns-backend-remote-3.4.8-2.el7.x86_64 (epel)
           Requires: libzmq.so.4()(64bit)

Expected results:

Additional info:
Library was renamed to libzmq.so.5 in zeromq 4.1.4-5.el7.

Rebuilding RPMs from pdns-3.4.8-2.el7.src.rpm seems to fix the problem.

Comment 1 Ruben Kerkhof 2016-07-22 16:04:54 UTC
Hmm, pdns was rebuild to pick up the soname change (https://bugzilla.redhat.com/show_bug.cgi?id=1301163) , but looking at the build logs the new zeromq wasn't in the buildroot at that time (https://kojipkgs.fedoraproject.org//packages/pdns/3.4.8/2.el7/data/logs/x86_64/root.log)

I'll do another rebuild.

Comment 2 Fedora Update System 2016-07-22 17:20:24 UTC
pdns-3.4.8-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-7e7f45981d

Comment 3 Fedora Update System 2016-07-23 21:46:31 UTC
pdns-3.4.8-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-7e7f45981d

Comment 4 Lutz Heermann 2016-07-25 15:02:11 UTC
The new packages (pdns, pdns-backend-remote) from epel-testing are working without any problems on my system (CentOS 7, x86_64).

Comment 5 Fedora Update System 2016-08-09 14:20:05 UTC
pdns-3.4.8-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.