Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359130 - ipa-server-install command fails to install IPA server.
Summary: ipa-server-install command fails to install IPA server.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-22 11:32 UTC by Nikhil Dehadrai
Modified: 2016-11-04 05:58 UTC (History)
4 users (show)

Fixed In Version: ipa-4.4.0-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:58:52 UTC


Attachments (Terms of Use)
ipaserver-install.log (deleted)
2016-07-22 11:32 UTC, Nikhil Dehadrai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Nikhil Dehadrai 2016-07-22 11:32:27 UTC
Created attachment 1182824 [details]
ipaserver-install.log

Description of problem:
ipa-server-install command failed during IPA server installation.

Version-Release number of selected component (if applicable):
ipa-server-4.4.0-3.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Setup RHEL7.3 Server base machine. 
(In my case Red Hat Enterprise Linux Server release 7.3 Beta (Maipo)) 
2. Use the latest repo link for RHEL73.
3. Initiate ipa server installation. (In my case this is triggered using automation)

Actual results:
After step3, IPA server install fails with following message inside the log:
2016-07-22T17:09:59Z DEBUG The ipa-server-install command failed, exception: ValueError: too many values to unpack
2016-07-22T17:09:59Z ERROR too many values to unpack
2016-07-22T17:09:59Z ERROR The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information

Expected results:
Installation using ipa-server-install command should be successful without any errors.

Additional info:
Refer attachment for ipa-server-install logs.

Comment 1 Martin Bašti 2016-07-22 11:36:00 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6117

Comment 4 Martin Bašti 2016-07-22 13:17:09 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/524719f420fa331b3a1d53d5d8bebdfee39c8371

Comment 5 Nikhil Dehadrai 2016-07-26 05:50:45 UTC
Server build:
ipa-server-4.4.0-3.el7.x86_64

Tested the bug for the ipaserver-install command by using the fix mentioned and the installation was successful this time.

Kindly refer the attachment for the installation.

Comment 8 Nikhil Dehadrai 2016-08-01 13:20:54 UTC
Server build:ipa-server-4.4.0-4.el7.x86_64

Verified the bug on the basis of following points:
1. Verified that ipa-server-install command is successful.
2. No error message is observed during installation.
3. Refer attachment for server-install.log

Thus on the basis of above points, marking bug as "VERIFIED".

Comment 10 errata-xmlrpc 2016-11-04 05:58:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.