Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359053 - gnome-shell-extension-sustmi-windowoverlay-icons is out-of-date
Summary: gnome-shell-extension-sustmi-windowoverlay-icons is out-of-date
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-sustmi
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Yader Velásquez
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-22 08:11 UTC by Ferry Huberts
Modified: 2017-08-30 06:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-30 06:20:17 UTC


Attachments (Terms of Use)

Description Ferry Huberts 2016-07-22 08:11:13 UTC
Description of problem:
gnome-shell-extension-sustmi-windowoverlay-icons.noarch is out-of-date

There is an up-to-date one on https://extensions.gnome.org/, please update

Comment 1 Ferry Huberts 2016-07-22 08:12:07 UTC
The one in Fedora does NOT support gnome 3.20 while the up-to-date one does

Comment 2 Andrew Toskin 2017-03-24 05:06:24 UTC
GNOME Tweak Tool shows a warning that the extension isn't compatible with the current shell, on Fedora 24 (GNOME 3.20). On Fedora 25 (GNOME 3.22), there is no warning, but the extension does not overlay icons on window previews in activities overview, like it's supposed to.

The currently packaged versions include a metadata.json property saying they're only compatible with GNOME Shell 3.0 and 3.2, but the upstream .json file (current master branch on GitHub) says it's compatible with GNOME 3.8+.

Comment 3 Fedora End Of Life 2017-07-25 21:58:20 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 4 Andrew Toskin 2017-07-26 02:24:53 UTC
This bug has been open for a long time. I'm a package maintainer for several other GNOME Shell extensions, so I could take over this package, if the current owner is not able to work on it anymore.

Comment 5 Andrew Toskin 2017-08-11 20:23:53 UTC
You there, yaderv?

I could understand you getting busy and not being able to work on this anymore. Come back just long enough to let me take over. Or just come back, whichever is fine :)

Comment 6 Jan Kurik 2017-08-15 07:27:53 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 7 Andrew Toskin 2017-08-30 06:20:17 UTC
Okay, so I've taken over the package and gotten it up to date with the latest from upstream. Package updates are being processed in Bodhi now.


Note You need to log in before you can comment on or make changes to this bug.