Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359052 - RFE: show VM interface IP address
Summary: RFE: show VM interface IP address
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
: 967726 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-22 08:09 UTC by Guido Günther
Modified: 2018-09-05 19:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-05 19:15:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Debian BTS 818473 None None None 2016-07-22 08:09:48 UTC

Description Guido Günther 2016-07-22 08:09:49 UTC
We have API to retrieve the VMs IPs since some time. It would be great if virt-manager would use it to display the VMs IP for easy ssh connecting.

I meant to look into this since quiet some time but did not get around to so filing this here as a "wish".

Comment 1 Cole Robinson 2016-07-26 13:10:35 UTC
yup it's been on my todo list for a while too :)

Comment 2 Cole Robinson 2016-08-15 15:52:22 UTC
*** Bug 967726 has been marked as a duplicate of this bug. ***

Comment 3 Ricardo Bánffy 2017-09-08 23:02:28 UTC
Do you (Colin, Guido) have any UI idea for it? My first impulse is to add a possible column with all obtainable IP addresses. Another possibility would be hover pop-up with a list so as not to clutter the grid.

Comment 4 Cole Robinson 2017-09-11 19:10:49 UTC
Ricardo, if you get a working example with any UI that will be 80% of the effort, we can discuss tweaking the UI on virt-tools-list once I have something to look at

Comment 5 Guido Günther 2017-09-14 10:21:15 UTC
Actually having it in the VMs overview page would be a first step. Having it in the main grid would be nice but since IPs should be copy/pasteable I don't have any good suggestions for the grid view.

Comment 6 Cole Robinson 2018-03-03 22:06:23 UTC
A contributor posted patches recently, but getting this working so it doesn't spam libvirt API calls will take some work:

https://www.redhat.com/archives/virt-tools-list/2018-March/msg00008.html

Comment 7 Cole Robinson 2018-09-05 19:15:53 UTC
Upstream has support for this now, listing IPs in the VM 'interface' details page


Note You need to log in before you can comment on or make changes to this bug.