Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359051 - discovered hosts link leads nowhere at main dashboard
Summary: discovered hosts link leads nowhere at main dashboard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Karnan
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: Console-2-GA
TreeView+ depends on / blocked
 
Reported: 2016-07-22 07:55 UTC by Martin Kudlej
Modified: 2016-08-23 19:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2016-08-23 19:57:50 UTC


Attachments (Terms of Use)
dead link (deleted)
2016-07-22 07:55 UTC, Martin Kudlej
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Martin Kudlej 2016-07-22 07:55:33 UTC
Created attachment 1182730 [details]
dead link

Description of problem:
If there is any discovered host there is link to discovered hosts at main dashboard in section "Hosts". It leads nowhere. Its value is https://mkudlej-usm1-server.usersys.redhat.com:10443/#/first

Version-Release number of selected component (if applicable):
ceph-ansible-1.0.5-27.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.33-1.el7scon.x86_64
rhscon-core-0.0.34-1.el7scon.x86_64
rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-ui-0.0.48-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. accept some nodes but not all of them
2. create cluster
3. check main dashboard

Actual results:
There is dead link in Hosts section.

Expected results:
All links will work at main dashboard.

Comment 2 Martin Kudlej 2016-07-22 08:11:32 UTC
The same issue is on Cluster dashboard

Comment 3 Martin Bukatovic 2016-07-22 09:11:18 UTC
Additional information: the link point to "#/first", which does nothing.

~~~
<a href="#/first" title="1 hosts discovered">
~~~

Comment 4 Martin Bukatovic 2016-07-26 09:25:15 UTC
Checking with: rhscon-ui-0.0.50-1.el7scon.noarch

And on both Main Dashboard and Cluster Dashboard, the New Hosts Discovered
counter links to the View and Accept Hosts properly.

Moving to VERIFIED.

Comment 6 errata-xmlrpc 2016-08-23 19:57:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.