Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359050 - Can update to itself via "yum install *update*.rpm"
Summary: Can update to itself via "yum install *update*.rpm"
Keywords:
Status: CLOSED DUPLICATE of bug 1364040
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Installation & Update
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ovirt-4.0.6
: ---
Assignee: Douglas Schilling Landgraf
QA Contact: Huijuan Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-22 07:50 UTC by Huijuan Zhao
Modified: 2016-10-24 14:41 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-24 14:41:48 UTC
oVirt Team: Node
rule-engine: ovirt-4.0.z+
mgoldboi: planning_ack+
fdeutsch: devel_ack+
cshao: testing_ack+


Attachments (Terms of Use)
All logs (deleted)
2016-07-22 08:14 UTC, Huijuan Zhao
no flags Details

Description Huijuan Zhao 2016-07-22 07:50:53 UTC
Description of problem:
After update to the latest build via "yum update", also can update to itself via "yum install *update*.rpm".
Should not permit update to itself after update to the latest build.

Version-Release number of selected component (if applicable):
1. Before update:
RHVH-7.2-20160718.1-RHVH-x86_64-dvd1.iso
redhat-virtualization-host-image-update-placeholder-4.0-0.20.el7.noarch
imgbased-0.7.2-0.1.el7ev.noarch
kernel-3.10.0-327.22.2.el7.x86_64
2. After update:
redhat-virtualization-host-4.0-20160714.5
redhat-virtualization-host-image-update-placeholder-4.0-0.20.el7.noarch
imgbased-0.7.2-0.1.el7ev.noarch
kernel-3.10.0-327.22.2.el7.x86_64


How reproducible:
100%


Steps to Reproduce:
1. Install RHVH-7.2-20160718.1-RHVH-x86_64-dvd1.iso
2. Reboot and login RHVH, register to RHSM and enable repos
   # imgbase layout
     rhvh-4.0-0.20160714.3
     +- rhvh-4.0-0.20160714.3+1
   # imgbase w
     [INFO] You are on rhvh-4.0-0.20160714.3+1
3. Update via "yum update"
   #yum update
4. Reboot and login new build: redhat-virtualization-host-4.0-20160714.5
   # imgbase layout
     rhvh-4.0-0.20160714.3
     +- rhvh-4.0-0.20160714.3+1
     rhvh-4.0-0.20160714.5
     +- rhvh-4.0-0.20160714.5+1
   # imgbase w
     [INFO] You are on rhvh-4.0-0.20160714.5+1
5. Load redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch.rpm and update again:
   # yum install redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch.rpm



Actual results:
1. After step5, it can access update process and can update to itself:
# yum install redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch.rpm
Loaded plugins: imgbased-warning, product-id, search-disabled-repos, subscription-manager
Warning: yum operations are not persisted across upgrades!
Examining redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch.rpm: redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch
Marking redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package redhat-virtualization-host-image-update.noarch 0:4.0-20160714.5.el7 will be obsoleting
---> Package redhat-virtualization-host-image-update-placeholder.noarch 0:4.0-0.20.el7 will be obsoleted
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================================================================================
 Package                                  Arch    Version               Repository                                                           Size
==================================================================================================================================================
Installing:
 redhat-virtualization-host-image-update  noarch  4.0-20160714.5.el7    /redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch  481 M
     replacing  redhat-virtualization-host-image-update-placeholder.noarch 4.0-0.20.el7

Transaction Summary
==================================================================================================================================================
Install  1 Package

Total size: 481 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Warning: RPMDB altered outside of yum.
  Installing : redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch                                                              1/2
warning: %post(redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch) scriptlet failed, exit status 1
Non-fatal POSTIN scriptlet failure in rpm package redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch
  Erasing    : redhat-virtualization-host-image-update-placeholder-4.0-0.20.el7.noarch                                                        2/2
  Verifying  : redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch                                                              1/2
  Verifying  : redhat-virtualization-host-image-update-placeholder-4.0-0.20.el7.noarch                                                        2/2

Installed:
  redhat-virtualization-host-image-update.noarch 0:4.0-20160714.5.el7                                                                            

Replaced:
  redhat-virtualization-host-image-update-placeholder.noarch 0:4.0-0.20.el7                                                                      

Complete!


Expected results:
1. After step5, should not update to itself, and can give warning message, such as:

Loaded plugins: imgbased-warning, product-id, search-disabled-repos, subscription-manager
Warning: yum operations are not persisted across upgrades!
Examining redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch.rpm: redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch
redhat-virtualization-host-image-update-4.0-20160714.5.el7.noarch.rpm: does not update installed package.
Error: Nothing to do


Additional info: 
After step5, can not update via "yum update", it will report like below:
# yum update
Loaded plugins: imgbased-warning, product-id, search-disabled-repos, subscription-manager
Warning: yum operations are not persisted across upgrades!
No packages marked for update

Comment 1 Huijuan Zhao 2016-07-22 08:14:46 UTC
Created attachment 1182733 [details]
All logs

Comment 2 Ryan Barry 2016-10-24 10:04:43 UTC
This looks like a duplicate of rhbz#1364040

Comment 3 Douglas Schilling Landgraf 2016-10-24 14:41:48 UTC
(In reply to Ryan Barry from comment #2)
> This looks like a duplicate of rhbz#1364040

Agreed.

*** This bug has been marked as a duplicate of bug 1364040 ***


Note You need to log in before you can comment on or make changes to this bug.