Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359032 - Upgrade to Rails 4.1.6+
Summary: Upgrade to Rails 4.1.6+
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: rubygem-rails
Version: rh-ror41
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2.4
Assignee: ruby maint
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks: 1357583
TreeView+ depends on / blocked
 
Reported: 2016-07-22 06:59 UTC by Lukas Zapletal
Modified: 2016-08-09 07:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-09 07:31:12 UTC


Attachments (Terms of Use)

Description Lukas Zapletal 2016-07-22 06:59:51 UTC
It fixes possible problems for STI (discovery plugins):

https://github.com/rails/rails/commit/257d65ed2ceb14dca6b1319355ed4f8a73540498

Here is the associated issue: https://github.com/rails/rails/issues/14785

As it was described in:

https://bugzilla.redhat.com/show_bug.cgi?id=1357583

This is data integrity bug, high importance, z-stream candidate.

Comment 2 Eric Helms 2016-07-28 17:09:18 UTC
Rails is provided by RHSCL and bugs relating to updating the version in a particular SCL should be directed there I feel given they maintain the SCL and patch levels on top.

Comment 4 Vít Ondruch 2016-07-29 11:31:20 UTC
I don't think that update to Rails 4.1.6+ is feasible, but I think that applying the patch linked in comment #1 should be doable.

Nevertheless, would you mind to elaborate what is the impact of the issues, to help us prioritize? From the bug 1357583, I'd say that you have workaround in place ...

Comment 5 Honza Horak 2016-07-29 11:40:04 UTC
Removing devel_ack set from previous team.

Comment 7 Lukas Zapletal 2016-08-09 07:31:12 UTC
You are right, Vít. We have a workaround in 6.2. I thought you regularly upgrade but it looks like you only backport security issues. Therefore we can close it.


Note You need to log in before you can comment on or make changes to this bug.