Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359031 - [Document] debug kernel dump explain
Summary: [Document] debug kernel dump explain
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Bhupesh Sharma
QA Contact: Emma Wu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-22 06:55 UTC by Qiao Zhao
Modified: 2017-08-01 09:31 UTC (History)
3 users (show)

Fixed In Version: kexec-tools-2.0.14-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:31:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2300 normal SHIPPED_LIVE kexec-tools bug fix and enhancement update 2017-08-01 12:40:58 UTC

Description Qiao Zhao 2016-07-22 06:55:08 UTC
Description of problem:
QE found some error/panic on 2nd kernel, like bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1352430
https://bugzilla.redhat.com/show_bug.cgi?id=1266622

I have talked with Dave Young, he said, "crashkernel=auto does not
support debug kernel because a lot of debug options been enabled."
I think we should announce this in our kexec-kdump-howto.txt file,
if anyone want to use kdump on debug kernel.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Qiao Zhao 2016-11-16 03:08:26 UTC
Now is 7.4, add 7.4.0 flag.

Comment 2 Bhupesh Sharma 2017-04-05 06:22:41 UTC
As discussed with Dave and Bao on IRC, the debug kernels cannot be reliably used as crash/kdump kernels when the crash kernel memory is setup using the 'crashkernel=auto' boot argument.

This is because the debug kernels might enable a number of features which might cause the memory used by the same to swell up, which cannot be reliably met by using 'crashkernel=auto' boot argument.

Will cook up a patch to mention this limitation in kexec-kdump-howto.txt file.

Comment 7 errata-xmlrpc 2017-08-01 09:31:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2300


Note You need to log in before you can comment on or make changes to this bug.