Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359029 - Topology creation fails with " User test-admin credentials not accepted
Summary: Topology creation fails with " User test-admin credentials not accepted
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Luis Pabón
QA Contact: Jonathan Holloway
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-22 06:36 UTC by Bhaskarakiran
Modified: 2016-11-23 23:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-05 16:09:24 UTC


Attachments (Terms of Use)

Description Bhaskarakiran 2016-07-22 06:36:46 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Bhaskarakiran 2016-07-22 06:50:56 UTC
Description of problem:
=======================
Topology creation is failing with the below error:

[root@dhcp43-179 ~]# heketi-cli topology load --json=topology2.json
Creating cluster ... ID: 14e951736a7b154d960d4eb4748c3da5
	Creating node dhcp42-132.lab.eng.blr.redhat.com ... ID: 6e516ceabf4eff927801def2065db4d8
		Adding device /dev/vdb ... Unable to add device: User test-admin credentials not accepted

	Creating node dhcp42-40.lab.eng.blr.redhat.com ... Unable to create node: User test-admin credentials not accepted

	Creating node dhcp43-159.lab.eng.blr.redhat.com ... Unable to create node: User test-admin credentials not accepted

This is a blocker. Unless we respin the heketi containter, its not working.


Version-Release number of selected component (if applicable):
=============================================================
Heketi version : 2.0.6

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Luis Pabón 2016-07-22 15:51:10 UTC
There is a change to the server which was introduced for more reliable communication with Kube/openshift.  Version 2.0.2 and previous for Heketi imported code from the master branch in OpenShift Origin 1.3+ (OSE 3.3).  Heketi 2.0.5+ imports from OpenShift Origin 1.2 (OSE 3.2) for stability and compatibility.

See: https://github.com/heketi/heketi/pull/400

Please attach any openshift and heketi logs which cause any issues.  We need to track it down if it happens.

Also make sure that the Heketi container running is version 2.0.6 or later. You can check from the logs or by executing the following inside the container: 
  $ heketi --version

Comment 5 Luis Pabón 2016-10-05 16:09:24 UTC
This looks like a configuration issue.  We have not seen this issue.


Note You need to log in before you can comment on or make changes to this bug.