Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359013 - [quick installer] can't install native ha environment
Summary: [quick installer] can't install native ha environment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: ---
Assignee: Samuel Munilla
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-22 06:01 UTC by Anping Li
Modified: 2016-08-18 19:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-18 19:29:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1639 normal SHIPPED_LIVE OpenShift Enterprise atomic-openshift-utils bug fix and enhancement update 2016-08-18 23:26:45 UTC

Description Anping Li 2016-07-22 06:01:47 UTC
Description of problem:
Can't install native ha by atomic-openshift-installer. there isn't installer.yaml under .config/openshift and unexpected group master_lb  is in .config/openshift/hosts


Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.2.14-1

How reproducible:
always

Steps to Reproduce:
1. atomic-openshift-installer to install Native HA environment
2. ls -al .config/openshift
3. check .config/openshift/hosts

Actual results:

1. 
#atomic-openshift-installer install
Welcome to the OpenShift Enterprise 3 installation.
<---snip--->
<---snip--->
*** Installation Summary ***

Hosts:
- ha1master1.example.com
  - OpenShift Master
  - OpenShift Node (Unscheduled)
  - Etcd Member
  - Storage
- ha1master2.example.com
  - OpenShift Master
  - OpenShift Node (Unscheduled)
  - Etcd Member
- ha1master3.example.com
  - OpenShift Master
  - OpenShift Node (Unscheduled)
  - Etcd Member
- ha1node1.example.com
  - OpenShift Node (Dedicated)
- ha1node2.example.com
  - OpenShift Node (Dedicated)Although if set docker_upgrade=false, Docker still be upgraded to 1.10.3.
- ha1master.example.com
  - Load Balancer (HAProxy)

Total OpenShift Masters: 3
Total OpenShift Nodes: 5

NOTE: Multiple Masters specified, this will be an HA deployment with a separate
etcd cluster. You will be prompted to provide the FQDN of a load balancer and
a host for storage once finished entering hosts.


WARNING: A minimum of 3 dedicated Nodes are recommended for an HA
deployment.

Gathering information from hosts...
ERROR: /root/.config/openshift/hosts:6: child group is not defined: (master_lb)
There was a problem fetching the required information. Please see /tmp/ansible.log for details

2.
[root@fedora ~]# ls -alh .config/openshift/
total 16K
drwxr-xr-x. 3 root root 4.0K Jul 22 05:56 .
drwxr-xr-x. 3 root root 4.0K Jul 22 05:50 ..
drwxr-xr-x. 2 root root 4.0K Jul 22 05:50 .ansible
-rw-r--r--. 1 root root  435 Jul 22 05:56 hosts


3. cat .config/openshift/hosts
[OSEv3:children]
nodes
masters
nfs
master_lb
etcd
lb

[OSEv3:vars]
ansible_log_path=/tmp/ansible.log
ansible_config=/usr/share/atomic-openshift-utils/ansible.cfg
ansible_ssh_user=root
openshift_master_default_subdomain=ha1.example.com
openshift_master_cluster_method=native
openshift_master_cluster_hostname=ha1master.example.com
openshift_master_cluster_public_hostname=ha1master.example.com
deployment_type=openshift-enterprise

[masters]
ha1master1.example.com
ha1master2.example.com
ha1master3.example.com

[etcd]
ha1master1.example.com
ha1master2.example.com
ha1master3.example.com

[nodes]
ha1master1.example.com  openshift_schedulable=False
ha1master2.example.com  openshift_schedulable=False
ha1master3.example.com  openshift_schedulable=False
ha1node1.example.com
ha1node2.example.com  containerized=True

[lb]
ha1master.example.com  openshift_hostname=ha1master.example.com openshift_public_hostname=ha1master.example.com ansible_connection=local

[nfs]
ha1master1.example.com


Expected results:
Can install native ha openshift

Additional info:

Comment 1 Samuel Munilla 2016-07-30 13:54:47 UTC
Fixed by https://github.com/openshift/openshift-ansible/pull/2239

Comment 3 Anping Li 2016-08-09 10:40:36 UTC
Verified and pass, the hosts file can be created as expected.

Comment 5 errata-xmlrpc 2016-08-18 19:29:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1639


Note You need to log in before you can comment on or make changes to this bug.