Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359006 - npm is uninstallable because of unmet dependencies resulting from version conflicts
Summary: npm is uninstallable because of unmet dependencies resulting from version con...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: npm
Version: 24
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: T.C. Hollingsworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-22 05:32 UTC by Adam Hunt
Modified: 2016-07-22 09:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-22 09:57:26 UTC


Attachments (Terms of Use)

Description Adam Hunt 2016-07-22 05:32:49 UTC
Description of problem:
  Attempts to install the npm package fail.

Version-Release number of selected component (if applicable):
  Version     : 3.5.4
  Release     : 5.fc24

How reproducible:
  Highly. Tested on multiple machines owned by multiple persons.

Steps to Reproduce:
  1. dnf upgrade --refresh
  2. dnf install npm
  3. observe error
  4. dnf install --allowerasing npm
  5. observe error

Actual results:
  Conflicting package versions leading to unresolved dependencies.

Expected results:
  An installed and fully functional npm resulting in a happy user/dev/admin/human.

Additional info:
  Example session:

    [adam@drogon]~% sudo dnf install npm      
    Last metadata expiration check: 0:01:17 ago on Thu Jul 21 22:24:34 2016.
    Error: installed package nodejs-1:4.4.6-2.fc24.x86_64 obsoletes npm < 3.5.4-6 provided by npm-3.5.4-5.fc24.noarch
    (try to add '--allowerasing' to command line to replace conflicting packages)
    [adam@drogon]~% sudo dnf install --allowerasing npm
    Last metadata expiration check: 0:02:31 ago on Thu Jul 21 22:24:34 2016.
    Error: installed package nodejs-1:4.4.6-2.fc24.x86_64 obsoletes npm < 3.5.4-6 provided by npm-3.5.4-5.fc24.noarch
    [adam@drogon]~%

Comment 1 Zuzana Svetlikova 2016-07-22 07:21:27 UTC
nodejs package currently provides npm, no need to install it explicitly.

Comment 2 Adam Hunt 2016-07-22 09:57:03 UTC
Thanks Zuzana. I'd swear that I had to install npm separately in the past and so I echoed my prior behavior. My mistake.

Out of curiosity, if the npm utility is included as a part of the nodejs packag what's the purpose of the npm package?


Note You need to log in before you can comment on or make changes to this bug.