Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1359001 - Fix spurious failures in ec.t
Summary: Fix spurious failures in ec.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1360575
TreeView+ depends on / blocked
 
Reported: 2016-07-22 04:58 UTC by Pranith Kumar K
Modified: 2017-03-27 18:16 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1360575 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:16:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2016-07-22 04:58:49 UTC
Description of problem:
    Problem:
    Because of timing issue sometimes the mount is unmounted
    even before the version is updated, this is leading to
    not triggering heals.
    
    Fix:
    One way to fix this would be to increate 'sleep 2' to 'sleep 10'
    but that would slow things down. I changed the way ec learns
    it needs xattr healing so that it triggers heals even when the
    xattrs are not marked correctly.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-07-22 04:59:51 UTC
REVIEW: http://review.gluster.org/14980 (tests: Fix timing issue in ec.t) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Vijay Bellur 2016-07-22 15:14:00 UTC
COMMIT: http://review.gluster.org/14980 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 1c9b229a860908ffc0c0134450c9218bc8079c22
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Fri Jul 22 10:25:49 2016 +0530

    tests: Fix timing issue in ec.t
    
    Problem:
    Because of timing issue sometimes the mount is unmounted
    even before the version is updated, this is leading to
    not triggering heals.
    
    Fix:
    One way to fix this would be to increate 'sleep 2' to 'sleep 10'
    but that would slow things down. I changed the way ec learns
    it needs xattr healing so that it triggers heals even when the
    xattrs are not marked correctly.
    
    Change-Id: I1c82041166443ae7079dd99b89ea2ed170233ba3
    BUG: 1359001
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/14980
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 3 Shyamsundar 2017-03-27 18:16:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.