Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358961 - vgsplit attempt of external origin volume fail with "Internal error: Referenced LV not listed in VG"
Summary: vgsplit attempt of external origin volume fail with "Internal error: Referen...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: David Teigland
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 23:03 UTC by Corey Marthaler
Modified: 2016-11-04 04:16 UTC (History)
8 users (show)

Fixed In Version: lvm2-2.02.161-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 04:16:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1445 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2016-11-03 13:46:41 UTC

Description Corey Marthaler 2016-07-21 23:03:26 UTC
Description of problem:
This is a regression of the proper failure "Can't split external origin EXT and pool pool between two Volume Groups."

SCENARIO - [split_thin_extorigin_with_pool_on_diff_pv]
Attempt to split out an external thin volume LV from VG

Create a thin pool, virt, and snapshot volumes in the same vg (different pvs)
Create LV to be used as an EXTERNAL origin device
lvcreate  -L 1G -n extorigin seven /dev/sdd1
Converting LV into an external thin origin device
lvconvert --thinpool seven/pool --originname EXT -T extorigin
  WARNING: Sum of all thin volume sizes (1.00 GiB) exceeds the size of thin pool seven/pool (100.00 MiB)!
lvcreate  -s /dev/seven/extorigin -n snap1
  WARNING: Sum of all thin volume sizes (2.00 GiB) exceeds the size of thin pool seven/pool (100.00 MiB)!
lvcreate  -s /dev/seven/extorigin -n snap2
  WARNING: Sum of all thin volume sizes (3.00 GiB) exceeds the size of thin pool seven/pool (100.00 MiB)!
lvcreate  -s /dev/seven/extorigin -n snap3
  WARNING: Sum of all thin volume sizes (4.00 GiB) exceeds the size of thin pool seven/pool (100.00 MiB)!

deactivating seven/pool
deactivating seven/extorigin
deactivating seven/EXT


[root@host-075 ~]# lvs -a -o +devices
  LV              VG            Attr       LSize   Pool Origin    Data%  Meta%  Move Log Cpy%Sync Convert Devices       
  EXT             seven         ori-------   1.00g                                                        /dev/sdg1(0)  
  extorigin       seven         Vwi---tz--   1.00g pool EXT                                                             
  [lvol0_pmspare] seven         ewi-------   4.00m                                                        /dev/sdh1(0)  
  pool            seven         twi---tz-- 100.00m                                                        pool_tdata(0) 
  [pool_tdata]    seven         Twi------- 100.00m                                                        /dev/sdh1(1)  
  [pool_tmeta]    seven         ewi-------   4.00m                                                        /dev/sdh1(26) 
  snap1           seven         Vwi---tz-k   1.00g pool extorigin                                                       
  snap2           seven         Vwi---tz-k   1.00g pool extorigin                                                       
  snap3           seven         Vwi---tz-k   1.00g pool extorigin                                                       

[root@host-075 ~]# vgsplit -n EXT seven ten
  Internal error: Referenced LV EXT not listed in VG ten.
  Internal error: Referenced PV /dev/sdg1 not listed in VG ten.


# Non regression behavior should be:
[root@host-085 ~]# vgsplit -n EXT seven ten
  Can't split external origin EXT and pool pool between two Volume Groups.



Version-Release number of selected component (if applicable):
3.10.0-472.el7.x86_64

lvm2-2.02.161-2.el7    BUILT: Wed Jul 20 07:48:14 CDT 2016
lvm2-libs-2.02.161-2.el7    BUILT: Wed Jul 20 07:48:14 CDT 2016
lvm2-cluster-2.02.161-2.el7    BUILT: Wed Jul 20 07:48:14 CDT 2016
device-mapper-1.02.131-2.el7    BUILT: Wed Jul 20 07:48:14 CDT 2016
device-mapper-libs-1.02.131-2.el7    BUILT: Wed Jul 20 07:48:14 CDT 2016
device-mapper-event-1.02.131-2.el7    BUILT: Wed Jul 20 07:48:14 CDT 2016
device-mapper-event-libs-1.02.131-2.el7    BUILT: Wed Jul 20 07:48:14 CDT 2016
device-mapper-persistent-data-0.6.2-1.el7    BUILT: Mon Jul 11 04:32:34 CDT 2016
cmirror-2.02.161-2.el7    BUILT: Wed Jul 20 07:48:14 CDT 2016
sanlock-3.4.0-1.el7    BUILT: Fri Jun 10 11:41:03 CDT 2016
sanlock-lib-3.4.0-1.el7    BUILT: Fri Jun 10 11:41:03 CDT 2016
lvm2-lockd-2.02.161-2.el7    BUILT: Wed Jul 20 07:48:14 CDT 2016

Comment 5 Corey Marthaler 2016-08-01 22:57:30 UTC
Fix verified in the latest rpms.


3.10.0-480.el7.x86_64
lvm2-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
lvm2-libs-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
lvm2-cluster-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-libs-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-event-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-event-libs-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-persistent-data-0.6.3-1.el7    BUILT: Fri Jul 22 05:29:13 CDT 2016
cmirror-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
sanlock-3.4.0-1.el7    BUILT: Fri Jun 10 11:41:03 CDT 2016
sanlock-lib-3.4.0-1.el7    BUILT: Fri Jun 10 11:41:03 CDT 2016
lvm2-lockd-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016



[root@host-078 ~]# lvs -a -o +devices
  LV              VG    Attr       LSize   Pool Origin     Devices
  EXT             seven ori-------   1.00g                 /dev/sdg1(0)
  extorigin       seven Vwi---tz--   1.00g pool EXT
  [lvol0_pmspare] seven ewi-------   4.00m                 /dev/sdb1(0)
  pool            seven twi---tz-- 100.00m                 pool_tdata(0)
  [pool_tdata]    seven Twi------- 100.00m                 /dev/sdb1(1)
  [pool_tmeta]    seven ewi-------   4.00m                 /dev/sdb1(26)
  snap1           seven Vwi---tz-k   1.00g pool extorigin
  snap2           seven Vwi---tz-k   1.00g pool extorigin
  snap3           seven Vwi---tz-k   1.00g pool extorigin

[root@host-078 ~]# vgsplit -n EXT seven ten
  Can't split external origin EXT and pool pool between two Volume Groups.

Comment 7 errata-xmlrpc 2016-11-04 04:16:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1445.html


Note You need to log in before you can comment on or make changes to this bug.