Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358950 - SELinux is preventing vboxdrv.sh from 'write' accesses on the file 60-vboxdrv.rules.
Summary: SELinux is preventing vboxdrv.sh from 'write' accesses on the file 60-vboxdrv...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5f98ef16e552231155d91dcc165...
: 1359927 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 21:20 UTC by volodya
Modified: 2018-05-30 17:44 UTC (History)
23 users (show)

Fixed In Version: selinux-policy-3.13.1-191.16.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-22 00:23:18 UTC


Attachments (Terms of Use)

Description volodya 2016-07-21 21:20:20 UTC
Description of problem:
SELinux is preventing vboxdrv.sh from 'write' accesses on the file 60-vboxdrv.rules.

*****  Plugin catchall (100. confidence) suggests   **************************

If вы считаете, что vboxdrv.sh следует разрешить доступ write к 60-vboxdrv.rules file по умолчанию.
Then рекомендуется создать отчет об ошибке.
Чтобы разрешить доступ, можно создать локальный модуль политики.
Do
allow this access for now by executing:
# ausearch -c 'vboxdrv.sh' --raw | audit2allow -M my-vboxdrvsh
# semodule -X 300 -i my-vboxdrvsh.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                unconfined_u:object_r:udev_rules_t:s0
Target Objects                60-vboxdrv.rules [ file ]
Source                        vboxdrv.sh
Source Path                   vboxdrv.sh
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-191.5.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.6.4-301.fc24.x86_64 #1 SMP Tue
                              Jul 12 11:50:00 UTC 2016 x86_64 x86_64
Alert Count                   2
First Seen                    2016-07-22 00:08:28 MSK
Last Seen                     2016-07-22 00:08:28 MSK
Local ID                      cdf534ba-6d32-42ed-aa77-f154e5cfca5d

Raw Audit Messages
type=AVC msg=audit(1469135308.219:298): avc:  denied  { write } for  pid=9775 comm="vboxdrv.sh" name="60-vboxdrv.rules" dev="sda3" ino=789324 scontext=system_u:system_r:init_t:s0 tcontext=unconfined_u:object_r:udev_rules_t:s0 tclass=file permissive=0


Hash: vboxdrv.sh,init_t,udev_rules_t,file,write

Version-Release number of selected component:
selinux-policy-3.13.1-191.5.fc24.noarch

Additional info:
reporter:       libreport-2.7.1
hashmarkername: setroubleshoot
kernel:         4.6.4-301.fc24.x86_64
reproducible:   Not sure how to reproduce the problem
type:           libreport

Comment 1 tuxor 2016-07-27 07:03:39 UTC
Description of problem:
1. install VirtualBox from the official web page.
2. reboot (it happens on every boot)

Version-Release number of selected component:
selinux-policy-3.13.1-191.5.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.6.4-301.fc24.x86_64
type:           libreport

Comment 2 Christophe GERARDIN 2016-07-27 09:14:33 UTC
Description of problem:
1) Download VirtualBox-5.1-5.1.2_108956_fedora24-1.x86_64.rpm from Oracle's website
2) Install with Gnome-Software

Version-Release number of selected component:
selinux-policy-3.13.1-191.5.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.6.4-301.fc24.x86_64
type:           libreport

Comment 3 Kirill Berezin 2016-07-30 21:19:03 UTC
Description of problem:
New version of VirtualBox changed they /usr/sbin/rcvvboxdrv to /usr/sbin/vboxconfig

Version-Release number of selected component:
selinux-policy-3.13.1-191.5.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.6.4-301.fc24.x86_64
type:           libreport

Comment 4 A. Lloyd Flanagan 2016-07-30 22:20:17 UTC
Description of problem:
install VirtualBox 5.1.2 from virtualbox.org

Version-Release number of selected component:
selinux-policy-3.13.1-191.5.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.6.4-301.fc24.x86_64
type:           libreport

Comment 5 aairey 2016-08-10 10:18:07 UTC
Description of problem:
Just tried to install virtualbox wiht command 'dnf install VirtualBox-5.1', according to: http://www.if-not-true-then-false.com/2010/install-virtualbox-with-yum-on-fedora-centos-red-hat-rhel/

Version-Release number of selected component:
selinux-policy-3.13.1-191.8.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.6.5-300.fc24.x86_64
type:           libreport

Comment 6 walter.cisco 2016-08-11 09:33:25 UTC
*** Bug 1366194 has been marked as a duplicate of this bug. ***

Comment 7 Max E 2016-08-12 08:43:43 UTC
Description of problem:
The SELinux flag seemed to happen after I had installed VirtualBox - VirtualBox-5.1-5.1.2_108956_fedora24-1.x86_64.rpm
- and the software tried to open up.

Version-Release number of selected component:
selinux-policy-3.13.1-191.8.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.6.5-300.fc24.x86_64
type:           libreport

Comment 8 mathew 2016-08-15 20:21:31 UTC
Description of problem:
Tried to install VirtualBox 5.1.

Version-Release number of selected component:
selinux-policy-3.13.1-191.10.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.6.5-300.fc24.x86_64
type:           libreport

Comment 9 Raffaello Bertini 2016-08-21 14:24:57 UTC
Description of problem:
recompiling the kernel after upgrade.

Version-Release number of selected component:
selinux-policy-3.13.1-191.12.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.6.6-300.fc24.x86_64
type:           libreport

Comment 10 Raffaello Bertini 2016-08-27 15:25:25 UTC
Description of problem:
rebuilding the kernel for vbox. installed from the rpm repo.
selinux preventend or uefi driver not signed

Version-Release number of selected component:
selinux-policy-3.13.1-191.12.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.6.6-300.fc24.x86_64
type:           libreport

Comment 11 Raffaello Bertini 2016-08-29 19:19:47 UTC
Description of problem:
sudo /sbin/vboxconfig.

i think the context in the rpm was wrong. not actually sure how to allow this without SELinux complaining...

Version-Release number of selected component:
selinux-policy-3.13.1-191.13.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.6.7-300.fc24.x86_64
type:           libreport

Comment 12 Lukas Vrabec 2016-08-30 12:11:56 UTC
I add fixes for this issue. This change will be in next update.

Comment 13 Lukas Vrabec 2016-08-30 12:12:09 UTC
*** Bug 1359927 has been marked as a duplicate of this bug. ***

Comment 14 Raffaello Bertini 2016-09-03 14:19:31 UTC
Description of problem:
/sbin/config

Version-Release number of selected component:
selinux-policy-3.13.1-191.13.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.6.7-300.fc24.x86_64
type:           libreport

Comment 15 Raffaello Bertini 2016-09-03 14:26:32 UTC
Description of problem:
/sbin/vboxconfig

Version-Release number of selected component:
selinux-policy-3.13.1-191.13.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.6.7-300.fc24.x86_64
type:           libreport

Comment 16 Raffaello Bertini 2016-09-03 16:32:16 UTC
Description of problem:
/sbin/vboxconfig

selinux permissive mode too.

Version-Release number of selected component:
selinux-policy-3.13.1-191.14.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.7.2-201.fc24.x86_64
type:           libreport

Comment 17 Andrej Šišila 2016-09-03 18:56:09 UTC
Description of problem:
I was trying to install Virtualbox 5.1.4, downloaded from official site as rpm package. During installation (via terminal)
selinux reported an alert. However, this message doesn't affect the functionality of Virtualbox. Virtual machines within
Virtualbox worked normally after installing Virtualbox Extension Pack.

Version-Release number of selected component:
selinux-policy-3.13.1-191.14.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.7.2-201.fc24.x86_64
type:           libreport

Comment 18 kj4ohh 2016-09-05 12:27:07 UTC
Description of problem:
Came up when I started VirtualBox

Version-Release number of selected component:
selinux-policy-3.13.1-191.8.fc24.noarch
selinux-policy-3.13.1-191.10.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.7.2-201.fc24.x86_64
type:           libreport

Comment 19 Grégory Salvan 2016-09-12 14:46:36 UTC
Description of problem:
while installing VirtualBox from Oracle website (dnf version definetly doesn't work)

Version-Release number of selected component:
selinux-policy-3.13.1-191.14.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.7.2-201.fc24.x86_64
type:           libreport

Comment 20 pasqual milvaques 2016-09-14 07:43:43 UTC
Version 5.1.6 of Virtualbox introduced a change about this:
Fedora 24: SELinux is preventing vboxdrv.sh from write access on the directory /etc/udev/rules.d. -> should be fixed in releases higher than 5.1.4
https://www.virtualbox.org/ticket/15816

In my machine this error isn't appearing anymore but I haver a new error:
SELinux is preventing vboxdrv.sh from create access on the file vbox-install.log.

Perhaps is a problem of my machine because I messed something in selinux ¿is the same happening to others?

Comment 21 Fedora Update System 2016-09-15 17:24:55 UTC
selinux-policy-3.13.1-191.16.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fe39b806b6

Comment 22 Fedora Update System 2016-09-16 00:52:32 UTC
selinux-policy-3.13.1-191.16.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fe39b806b6

Comment 23 Fedora Update System 2016-09-22 00:23:18 UTC
selinux-policy-3.13.1-191.16.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.