Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358949 - RHEV deployment fails at 4% during Actions::Fusor::Host::TriggerProvisioning with exception: NoMethodError: undefined method `warning' for <Logging::Logger:0x431c514 name="app">:Logging::Logger
Summary: RHEV deployment fails at 4% during Actions::Fusor::Host::TriggerProvisioning ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: fusor-server
Version: 1.0
Hardware: All
OS: All
medium
medium
Target Milestone: ga
: 1.0
Assignee: dgao
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 21:18 UTC by Landon LaSmith
Modified: 2016-09-13 16:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:33:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Landon LaSmith 2016-07-21 21:18:18 UTC
Description of problem: During a new redeployment RHEV reusing the same hardware, RHV deployment fails at 4% during Actions::Fusor::Host::TriggerProvisioning. Exception message is "NoMethodError: undefined method `warning' for <Logging::Logger:0x431c514 name="app">:Logging::Logger"

ISO Media Version: 1468874026.17478

How reproducible: Intermittent. I've only hit it twice and only while kicking off a new deployment after a QCI dev has debugged a previously failed deployment <no blame>


Steps to Reproduce:
1. Install QCI
2. Deploy RHEV and wait for it to succeed or fail
3. Delete any RHEV/CFME/OSE hosts in Satellite that were used in a previous deployment
4. Rediscover the same RHEV hosts used earlier
4. Possibly repeat step 2-4 a few times
5. Create and start a new RHEV deployment with any optional products

Actual results: QCI fails at 4% during RHV deployment


Expected results: RHV deployment proceeds as planned


Additional info:

Comment 2 John Matthews 2016-07-21 21:23:00 UTC
I'm not sure if it's related, but last week I did a deployment in devel env and saw all of satellite logging break. 

In my case, deployment was running slow and a connection to the DB timed out, it raised an exception with logging and logging for rest of deployment was broken, as in the sat logging for log/development.log

our own deployment logs were still going.

traceback I saw is below.
https://gist.github.com/anonymous/1a4de27443881c58f6cbb9909001fa6b

Also worth noting we did add some logging improvements to help with quieting the logs, that functionality is turned off in production deployments, configured in fusor.yaml...but might be related as well.

Comment 3 John Matthews 2016-07-21 21:23:10 UTC
I'm not sure if it's related, but last week I did a deployment in devel env and saw all of satellite logging break. 

In my case, deployment was running slow and a connection to the DB timed out, it raised an exception with logging and logging for rest of deployment was broken, as in the sat logging for log/development.log

our own deployment logs were still going.

traceback I saw is below.
https://gist.github.com/anonymous/1a4de27443881c58f6cbb9909001fa6b

Also worth noting we did add some logging improvements to help with quieting the logs, that functionality is turned off in production deployments, configured in fusor.yaml...but might be related as well.

Comment 5 Landon LaSmith 2016-07-21 21:35:35 UTC
After "katello-service restart", I was unable to resume the failed deployment task and new deployments experienced the same issue.

Comment 6 John Matthews 2016-08-08 17:26:44 UTC
Landon,

We aren't able to reproduce this issue.
Moving this back to ON_QA.

If you can reproduce, please help us find the reproducer steps.

Comment 7 Landon LaSmith 2016-08-25 17:47:48 UTC
(In reply to John Matthews from comment #6)
> Landon,
> 
> We aren't able to reproduce this issue.
> Moving this back to ON_QA.
> 
> If you can reproduce, please help us find the reproducer steps.

As of right now, I don't know of any way to reproduce this issue so feel free to move this to CLOSED CURRENTRELEASE and Ill reopen if I encounter it again.

Comment 8 Tasos Papaioannou 2016-08-25 20:19:09 UTC
Haven't been able to reproduce this issue. The original error indicated that the 'warning' method for the logger instance couldn't be found, and the line in trigger_provisioning.rb that called this method no longer exists (commit shown below), so I'll marked this as Verified.

****

commit 4433992e82dbaaa96147498d6122de45868d1ced
Author: Fabian von Feilitzsch <fabian@fabianism.us>
Date:   Mon Jul 18 15:57:09 2016 -0400

    catch conversion errors on host

diff --git a/server/app/lib/actions/fusor/host/trigger_provisioning.rb b/server/app/lib/actions/fusor/host/trigger_provisioning.rb
index 383201d..f0ee88a 100644
--- a/server/app/lib/actions/fusor/host/trigger_provisioning.rb
+++ b/server/app/lib/actions/fusor/host/trigger_provisioning.rb
@@ -108,8 +108,12 @@ module Actions
             ::Fusor.log.debug "saving host of type: #{host.type}"
             ::Fusor.log.debug "calling save"
 
+            # We have to do this manually instead of using host.save! because of a bug in Rails < 4.1.6
+            # https://engineering.redhat.com/trac/RHCI/wiki/Debugging/KnownIssues#host.saveisntpersistingmyrecordandnoerrorsarethrown
             rc = host.save
-            ::Fusor.log.warning "Host save failed. #{host}" if !rc
+            successful_save = rc && host.reload.type == 'Host::Managed'
+
+            fail _("Host with id #{host.id} was not converted to a managed host.") unless successful_save
 
             return host
           end

****

Comment 10 errata-xmlrpc 2016-09-13 16:33:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.