Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358939 - Review Request: perl-Dancer2-Plugin-REST - Plugin for writing RESTful apps with Dancer2
Summary: Review Request: perl-Dancer2-Plugin-REST - Plugin for writing RESTful apps wi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 20:13 UTC by Emmanuel Seyman
Modified: 2016-08-13 11:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-13 11:10:37 UTC
ppisar: fedora-review+


Attachments (Terms of Use)

Description Emmanuel Seyman 2016-07-21 20:13:37 UTC
Spec URL: http://people.parinux.org/~seyman/fedora/perl-Dancer2-Plugin-REST/perl-Dancer2-Plugin-REST.spec
SRPM URL: http://people.parinux.org/~seyman/fedora/perl-Dancer2-Plugin-REST/perl-Dancer2-Plugin-REST-0.27-1.fc24.src.rpm
Description: 
Fedora Account System Username: eseyman
Rpmlint Output: 1 packages and 1 specfiles checked; 0 errors, 0 warnings.

Comment 1 Emmanuel Seyman 2016-07-21 20:17:32 UTC
(In reply to Emmanuel Seyman from comment #0)
>
> Description: 
This plugin helps you write a RESTful web-service with Dancer2.

Comment 2 Petr Pisar 2016-07-26 11:56:55 UTC
URL and Source0 addresses are usable. Ok.
Source archive is original (SHA-256: 91c2b7d8e707a4cf68cf17735eb845bce9e32fc0c59e5f7bd1d94c1874e002b7). Ok.
Summary verified from lib/Dancer2/Plugin/REST.pm. Ok.
Description is Ok.
License verified from README.mkdn, LICENSE, lib/Dancer2/Plugin/REST.pm. Ok.
No XS code, noarch BuildArch is Ok.

TODO: Constrain `perl(Dancer2)' dependency with a version (META.json:33).

All tests pass. Ok.

$ rpmlint perl-Dancer2-Plugin-REST.spec ../SRPMS/perl-Dancer2-Plugin-REST-0.27-1.fc25.src.rpm ../RPMS/noarch/perl-Dancer2-Plugin-REST-0.27-1.fc25.noarch.rpm 
2 packages and 1 specfiles checked; 0 errors, 0 warnings.
rpmlint is Ok.

$ rpm -q -lp -v ../RPMS/noarch/perl-Dancer2-Plugin-REST-0.27-1.fc25.noarch.rpm 
drwxr-xr-x    2 root    root                        0 Jul 26 13:45 /usr/share/doc/perl-Dancer2-Plugin-REST
-rw-r--r--    1 root    root                     2833 Dec 29  2015 /usr/share/doc/perl-Dancer2-Plugin-REST/Changes
-rw-r--r--    1 root    root                     3122 Dec 29  2015 /usr/share/doc/perl-Dancer2-Plugin-REST/README
-rw-r--r--    1 root    root                     3506 Dec 29  2015 /usr/share/doc/perl-Dancer2-Plugin-REST/README.mkdn
drwxr-xr-x    2 root    root                        0 Jul 26 13:45 /usr/share/licenses/perl-Dancer2-Plugin-REST
-rw-r--r--    1 root    root                    18355 Dec 29  2015 /usr/share/licenses/perl-Dancer2-Plugin-REST/LICENSE
-rw-r--r--    1 root    root                     2613 Jul 26 13:44 /usr/share/man/man3/Dancer2::Plugin::REST.3pm.gz
drwxr-xr-x    2 root    root                        0 Jul 26 13:44 /usr/share/perl5/vendor_perl/Dancer2
drwxr-xr-x    2 root    root                        0 Jul 26 13:44 /usr/share/perl5/vendor_perl/Dancer2/Plugin
-rw-r--r--    1 root    root                     8039 Dec 29  2015 /usr/share/perl5/vendor_perl/Dancer2/Plugin/REST.pm
File layout and permissions are Ok.

$ rpm -q --requires -p ../RPMS/noarch/perl-Dancer2-Plugin-REST-0.27-1.fc25.noarch.rpm | sort -f | uniq -c
      1 perl(:MODULE_COMPAT_5.24.0)
      1 perl(Carp)
      1 perl(Class::Load)
      1 perl(Dancer2::Plugin)
      1 perl(strict)
      1 perl(warnings)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
Binary requires are Ok.

$ rpm -q --provides -p ../RPMS/noarch/perl-Dancer2-Plugin-REST-0.27-1.fc25.noarch.rpm | sort -f | uniq -c
      1 perl(Dancer2::Plugin::REST) = 0.27
      1 perl-Dancer2-Plugin-REST = 0.27-1.fc25
Binary provides are Ok.

$ resolvedeps rawhide ../RPMS/noarch/perl-Dancer2-Plugin-REST-0.27-1.fc25.noarch.rpm 
Binary dependencies resolvable. Ok.

Package builds in F25 (http://koji.fedoraproject.org/koji/taskinfo?taskID=15023162). Ok.

Package is in line with Fedora and Perl packaging guidelines.

Please consider fixing the `TODO' item before building this package.
Resolution: Package APPROVED.

Comment 3 Emmanuel Seyman 2016-07-28 08:26:02 UTC
(In reply to Petr Pisar from comment #2)
> 
> TODO: Constrain `perl(Dancer2)' dependency with a version (META.json:33).

I've constrained perl(Dancer2)  to 0.149000 or higher (although I'm not sure how useful this is, given that the first version of Dancer2 to be imported in Fedora was 0.158000 .

I've also requested the repo in pkgdb.

> Please consider fixing the `TODO' item before building this package.
> Resolution: Package APPROVED.

Spec URL: http://people.parinux.org/~seyman/fedora/perl-Dancer2-Plugin-REST/perl-Dancer2-Plugin-REST.spec
SRPM URL: http://people.parinux.org/~seyman/fedora/perl-Dancer2-Plugin-REST/perl-Dancer2-Plugin-REST-0.27-2.fc24.src.rpm

Thank you for the review, Petr.

Comment 4 Gwyn Ciesla 2016-07-28 13:15:08 UTC
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/perl-Dancer2-Plugin-REST

Comment 5 Emmanuel Seyman 2016-08-13 11:10:37 UTC
This package has been imported in Fedora and updates have been issued for the currently supported versions of Fedora.


Note You need to log in before you can comment on or make changes to this bug.