Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358864 - Update from Scientific Linux 6.7 to Scientific Linux 6.8 fails due to missing library for NetworkManager-openconnect
Summary: Update from Scientific Linux 6.7 to Scientific Linux 6.8 fails due to missing...
Keywords:
Status: CLOSED DUPLICATE of bug 1357965
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: NetworkManager-openconnect
Version: el6
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 16:05 UTC by Keith
Modified: 2016-07-21 17:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-21 17:50:34 UTC


Attachments (Terms of Use)

Description Keith 2016-07-21 16:05:23 UTC
Description of problem:
Upgrade from Scientific Linux 6.7 to 6.8 fails if NetworkManager-openconnect is installed

Version-Release number of selected component (if applicable):
Old openconnect.i686                5.03-3.el6
New openconnect.i686                7.06-1.el6  
NetworkManager-openconnect.i686     0.8.6.0-2.el6

How reproducible: 100%


Steps to Reproduce:
1. Attempt upgrade installation from EL6.7 to EL6.8 with openconnect and NetworkManager-openconnect installed
2. 
3.

Actual results: Upgrade fails, NetworkManager-openconnect 0.8.6.0-2.el6 requires libopenconnect.so.2, openconnect.i686 7.06-1.el6 provides libopenconnect.so.5


Expected results: Upgrade proceeds without error


Additional info: Upgrade proceeds as expected if NetworkManager-openconnect is removed prior to starting upgrade.

In /pub/epel/6/i386/ directory, 
openconnect rpm timestamp = 2016-06-21 18:26 
NetworkManager-openconnect rpm timestamp is 2013-07-03 18:53

I suspect that the NetworkManager-openconnect package has not been updated to keep it in step with the updated openconnect package.

Comment 1 Rex Dieter 2016-07-21 17:50:34 UTC

*** This bug has been marked as a duplicate of bug 1357965 ***


Note You need to log in before you can comment on or make changes to this bug.