Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358857 - 'tuned-adm list' can cause tracebeck if daemon is not running
Summary: 'tuned-adm list' can cause tracebeck if daemon is not running
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 15:33 UTC by Jaroslav Škarvada
Modified: 2016-11-04 07:28 UTC (History)
3 users (show)

Fixed In Version: tuned-2.7.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:28:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2479 normal SHIPPED_LIVE tuned bug fix and enhancement update 2016-11-03 14:08:42 UTC

Description Jaroslav Škarvada 2016-07-21 15:33:05 UTC
Description of problem:
Due to the typo in the code 'tuned-adm list' can cause traceback if Tuned daemon is not running.

Version-Release number of selected component (if applicable):
tuned-2.7.0

How reproducible:
Always

Steps to Reproduce:
1. systemctl stop tuned
2. tuned-adm list

Actual results:
Traceback

Expected results:
No traceback

Additional info:
AFAIK we have no test case for such scenario. Test should be added.

Comment 1 Jaroslav Škarvada 2016-07-21 15:34:18 UTC
Fixed by the following upstream commit:
https://git.fedorahosted.org/cgit/tuned.git/commit/?id=e6b647641bbb17f36f804ba22dda198478d8533b

Comment 5 errata-xmlrpc 2016-11-04 07:28:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2479.html


Note You need to log in before you can comment on or make changes to this bug.