Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358829 - QCI 1.2: Disconnected: 'Missing http protocol' while verifying Content Mirror URL
Summary: QCI 1.2: Disconnected: 'Missing http protocol' while verifying Content Mirror...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 1.0
Assignee: Erik Nelson
QA Contact: James Olin Oden
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 14:48 UTC by Antonin Pagac
Modified: 2016-09-13 16:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:33:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Antonin Pagac 2016-07-21 14:48:16 UTC
Description of problem:
When doing a disconnected deployment, when pasting a link to the Content Mirror URL field, there is an error:

'Missing http protocol'

The link is to the known server we use when we are trying disconnected mode. The link looks like:

'​http://<retracted>/pub/sat-import'

I can ping the server and it seems to be up. There is no message about checking link in production.log. I tried also supplying invalid URL or leave the field blank, the error is always the same.

Version-Release number of selected component (if applicable):
20160720.t.0

How reproducible:
Always

Steps to Reproduce:
1. Start a deployment, go to the Subscriptions section
2. Click on 'No, Satellite will have restricted network access.'
3. Supply a valid link to the Content Mirror URL field
4. After a while the error appears bellow the field

Actual results:
'Missing http protocol' appears when valid link is supplied

Expected results:
No error should appear when valid link is supplied

Additional info:

Comment 1 Antonin Pagac 2016-07-21 15:00:00 UTC
Update: I looked at the logs and it seems that there was some whitespace character copied with the link to the server. It was not visible in the field with the link when I pasted it there. When I deleted first part of the link and re-typed manually, the checking works as expected:

'Content mirror verified'

In the log the link looked like this:

"cdn_url"=>"<200b>http://<retracted>/pub/sat-import"

I leave it up to somebody else, if we want to implement some kind of checking for this, or just close this BZ.

Comment 3 Erik Nelson 2016-07-26 14:38:06 UTC
I'll add a warning if whitespace is found in the supplied URL, at least that should call attention to it directly.

Comment 4 Erik Nelson 2016-07-26 15:01:34 UTC
PR: https://github.com/fusor/fusor/pull/1095

Comment 5 John Matthews 2016-08-02 18:44:03 UTC
QCI-1.0-RHEL-7-20160801.t.2-QCI-x86_64-dvd1.iso

Comment 6 James Olin Oden 2016-08-15 14:21:54 UTC
Verified for QCI-1.0-RHEL-7-20160812.t.0

Did the steps listed above but entered a URL with a space at the end.   The 
application now says:

   URL contains whitespace

which is what we want.

Comment 8 errata-xmlrpc 2016-09-13 16:33:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.