Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358813 - Clicking on satellite navigation menu while on any wizard page takes you to product selection page
Summary: Clicking on satellite navigation menu while on any wizard page takes you to p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 1.0
Assignee: cchase
QA Contact: bmorriso
URL: https://github.com/fusor/fusor/pull/1075
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 14:16 UTC by bmorriso
Modified: 2016-09-13 16:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:33:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC
Red Hat Bugzilla 1358844 None None None Never

Internal Links: 1358844

Description bmorriso 2016-07-21 14:16:06 UTC
Description of problem:

From any page within the New Deployment wizard (or the Deployments page itself), if a user clicks on the Satellite navigation menu, they will return to the product selection page. 

Version-Release number of selected component (if applicable):
QCI-1.2-RHEL-7-20160720.t.0

How reproducible:
always

Steps to Reproduce:
1. From the WebUI, start a New Deployment.
2. Select Products, click Next
3. Click on one of the dropdowns on the navigation menu at top of page

Actual results:
User is returned to product selection page

Expected results:
Dropdown menu would appear

Additional info:
Once this behavior has begun, the only way I have found to get out of it is clicking on "Red Hat Satellite" on the top left of the page.

Comment 2 cchase 2016-07-21 17:57:51 UTC
https://github.com/fusor/fusor/pull/1075

Had to back out change fixing the back button. https://bugzilla.redhat.com/show_bug.cgi?id=1354470

Comment 8 John Matthews 2016-07-25 12:41:00 UTC
QCI-1.0-RHEL-7-20160723.t.0-QCI-x86_64-dvd1.iso

Comment 9 bmorriso 2016-08-11 19:52:39 UTC
Verified in compose QCI-1.0-RHEL-7-20160809.t.1

From pages within the wizard, I am able to use the nagivation menu as exected and not just get redirected to the product selection page.

Comment 11 errata-xmlrpc 2016-09-13 16:33:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.