Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358808 - QCI 1.2: New Subscription Management Application permits trailing space in the name; spaces are accepted as valid name
Summary: QCI 1.2: New Subscription Management Application permits trailing space in th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 1.0
Assignee: Erik Nelson
QA Contact: bmorriso
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 14:07 UTC by Antonin Pagac
Modified: 2016-09-13 16:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:33:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Antonin Pagac 2016-07-21 14:07:26 UTC
Description of problem:
When creating new SMA with QCI, I'm allowed to have trailing space in the name or input just all-spaces name and it gets added successfully.

When trying to add this via the portal, there is an error:

"Name may only contain letters, numbers, period, underscore, or hyphen."

There's an old bug 1286238 that talks about invalid characters. The checking for bad characters now seems to work just fine with the exception of space characters described in this bug.

Version-Release number of selected component (if applicable):
20160720.t.0

How reproducible:
Always

Steps to Reproduce:
1. Do a deployment, go to the Subscriptions section
2. Click on the 'New Subscription Management Application' button
3. Input valid name and then space; it gets accepted
4. Input just one or more spaces; it gets accepted

Actual results:
SMA with invalid name is created; this might present possible problems with the deployment further on

Expected results:
SMA with invalid name should not be created; the check for invalid characters should catch trailing space and all-spaces name

Additional info:

Comment 2 Erik Nelson 2016-07-26 14:35:30 UTC
PR: https://github.com/fusor/fusor/pull/1094

Comment 3 John Matthews 2016-08-02 18:44:11 UTC
QCI-1.0-RHEL-7-20160801.t.2-QCI-x86_64-dvd1.iso

Comment 4 bmorriso 2016-08-11 19:45:51 UTC
Failed to verify this on QCI-1.0-RHEL-7-20160809.t.1

When trying to add a new subscription management application on page '4B. Subscription Management Applications': 

A name that is just whitespace is rejected with an error message: 'failed to be added. Invalid application name.'

However, a name with trailing whitespace like "newname    " will trim all but the last space and be accepted: "newname ".

When trying to add a new SMA with trailing whitespace via access.redhat.com it is rejected outright, and is not trimmed and accepted.

Comment 5 Erik Nelson 2016-08-12 13:46:14 UTC
PR: https://github.com/fusor/fusor/pull/1155

Comment 6 Erik Nelson 2016-08-17 12:30:58 UTC
Has this been reviewed since the latest PR? I'm assuming this leaked though and should be ON_QA right now.

Comment 7 bmorriso 2016-08-17 15:07:29 UTC
Verified this on compose QCI-1.0-RHEL-7-20160816.t.0

When trying to add a new subscription management application on page '4B. Subscription Management Applications', if the name provided has any leading or trailing whitespace, it is rejected with the error message:

'Invalid application name, should contain alphanumeric characters with no whitespace.'

Comment 9 errata-xmlrpc 2016-09-13 16:33:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.