Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358794 - [UI] Update UI-plugin authentication mechanism to use the ssoToken
Summary: [UI] Update UI-plugin authentication mechanism to use the ssoToken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-optimizer
Classification: Retired
Component: General
Version: 0.10
Hardware: Unspecified
OS: Unspecified
urgent
urgent vote
Target Milestone: ovirt-4.0.5
: 0.11
Assignee: Phillip Bailey
QA Contact: Shira Maximov
URL:
Whiteboard:
Depends On: 1376370
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-21 13:26 UTC by Phillip Bailey
Modified: 2017-01-18 07:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this update, an updated authentication mechanism for ovirt engine communication has been added. The ovirt UI-plugin infrastructure was updated to streamline the authentication process. However, this change is not backwards compatible with the previous method of authentication and made all UI-plugins using the old method unable to authenticate with the engine. Now, the ovirt-optimizer UI-plugin is able to authenticate with the engine using the new authentication mechanism.
Clone Of:
Environment:
Last Closed: 2017-01-18 07:38:25 UTC
oVirt Team: SLA
rule-engine: ovirt-4.0.z+
mgoldboi: planning_ack+
rgolan: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 61338 None None None 2016-08-22 12:03:57 UTC

Description Phillip Bailey 2016-07-21 13:26:36 UTC
Description of problem:
The ovirt-optimizer UI-plugin is using a deprecated authentication mechanism that prevents it from authenticating with the REST API.

How reproducible: 
100%

Steps to Reproduce:
1. Have a setup with optimizer installed.
2. Navigate to the Optimizer Result sub tab under the Clusters main tab.

Actual results:
The status message in the Solution Status section displays "REST session has not been authenticated yet" and no data is displayed in the Target State section.

Expected results:
There should be no solution Status Section and data should be displayed in the Target State section.

Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2016-07-26 15:08:58 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 2 Roy Golan 2016-07-26 15:11:27 UTC
The reason for the prio is because without the fix the plugin doesn't work which renders the optimizer useless

Comment 3 Gil Klein 2016-09-29 12:22:01 UTC
The verification did not take place due to BZ #1376370.

While 4.0.4 was already released , this BZ will be verified as part of 4.0.5

Comment 4 Shira Maximov 2016-10-13 14:24:17 UTC
verified on :
Red Hat Virtualization Manager Version: 4.0.5.1-0.1.el7ev


verification steps: 
1. Have a setup with optimizer installed.
2. Navigate to the Optimizer Result sub tab under the Clusters main tab.


Note You need to log in before you can comment on or make changes to this bug.