Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358704 - upgrade from 1.3.2 to 2.0 fails to convert old multisite configuration
Summary: upgrade from 1.3.2 to 2.0 fails to convert old multisite configuration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 2.0
Assignee: Matt Benjamin (redhat)
QA Contact: shilpa
URL:
Whiteboard:
Depends On:
Blocks: 1363819
TreeView+ depends on / blocked
 
Reported: 2016-07-21 10:06 UTC by Orit Wasserman
Modified: 2017-07-30 15:52 UTC (History)
13 users (show)

Fixed In Version: RHEL: ceph-10.2.2-25.el7cp Ubuntu: ceph_10.2.2-20redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-15 11:17:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1898 normal SHIPPED_LIVE Red Hat Ceph Storage 2 bug fix and enhancement update 2017-03-22 02:06:31 UTC
Ceph Project Bug Tracker 16751 None None None 2016-07-21 10:06:51 UTC

Description Orit Wasserman 2016-07-21 10:06:52 UTC
Description of problem:
Upgrade 1.3.2 with old multisite config (regions and zones) to 2.0 doesn't convert the old configuration correctly

Version-Release number of selected component (if applicable):


How reproducible:
Upgrade a 1.3.2 cluster with multisite config to 2.0

Steps to Reproduce:
1. Configure multisite on 1.3.2 (at least one region)
2. Upgrade to 2.0
3. check to configuration


Actual results:
radosgw-admin zone list is empty
radosgw-admin zonegroup list is empty
Expected results:
radosgw-admin zone list returns previous configured zones
radosgw-admin zonegroup returns list of previous configured regions

Additional info:

Comment 2 Orit Wasserman 2016-07-21 10:07:55 UTC
upstream fix: https://github.com/ceph/ceph/pull/10368

Comment 3 Ken Dreyer (Red Hat) 2016-07-21 13:41:03 UTC
Matt will cherry-pick this to ceph-2-rhel-patches today

Comment 19 errata-xmlrpc 2016-09-15 11:17:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1898.html


Note You need to log in before you can comment on or make changes to this bug.