Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358509 - VMware vCenter Provider : VM reconfigure (powered on or off) add disk error when more than 1 disk present
Summary: VMware vCenter Provider : VM reconfigure (powered on or off) add disk error w...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: All
OS: Unspecified
high
high
Target Milestone: GA
: 5.5.6
Assignee: Drew Bomhof
QA Contact: Dave Johnson
URL:
Whiteboard: vmware:reconfigure
Depends On: 1336812
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 21:10 UTC by John Prause
Modified: 2017-08-16 17:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1336812
Environment:
Last Closed: 2017-08-16 17:29:25 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 2 CFME Bot 2016-08-02 22:01:38 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=a4c2c29c15c53beba9cd5d12b14194bc600e721d

commit a4c2c29c15c53beba9cd5d12b14194bc600e721d
Merge: 84070f6 a711f10
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Tue Aug 2 17:58:25 2016 -0400
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Tue Aug 2 17:58:25 2016 -0400

    Merge branch '5.5.z_vm_reconfig_more_than_one_disk' into '5.5.z'
    
    Fix calculation of the controller and unit number
    
    When calculating the controller key and unit number detect was
    used so that if there were more than 1 scsi controller or
    virtual disk on the target vm the new disk would be added to
    a populated slot on the scsi controller, leading to the error
    message from VMware "Invalid configuration for device '0'"
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1358509
    
    PR: https://github.com/ManageIQ/manageiq/pull/8791
    
    Cherry-pick was clean
    
    See merge request !1029

 gems/pending/VMwareWebService/MiqVimVm.rb          |  36 ++-
 .../pending/spec/VMwareWebService/MiqVimVm_spec.rb | 347 ++++++++++++++++++---
 2 files changed, 337 insertions(+), 46 deletions(-)

Comment 3 Chris Pelland 2017-08-16 17:29:25 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.