Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358488 - VMware VM Reconfigure Add Disk fails when a new SCSI controller is needed
Summary: VMware VM Reconfigure Add Disk fails when a new SCSI controller is needed
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.5.6
Assignee: Drew Bomhof
QA Contact: luke couzens
URL:
Whiteboard: reconfigure:vmware
Depends On: 1337310
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 20:03 UTC by John Prause
Modified: 2017-08-16 17:29 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1337310
Environment:
Last Closed: 2017-08-16 17:29:07 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
hotfix (deleted)
2016-07-30 16:12 UTC, Greg McCullough
no flags Details

Comment 2 Adam Grare 2016-07-20 20:53:12 UTC
This fixed an issue when adding multiple disks through the vm/reconfigure UI page.  This feature didn't exist on 5.5 so there is nothing to back port.

Comment 3 Greg McCullough 2016-07-30 16:12:38 UTC
Created attachment 1185822 [details]
hotfix

Patch to MiqVimVm.rb.

Comment 5 CFME Bot 2016-08-03 17:07:09 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=f95a413b99894dea24645abd791c6b4d200e38f4

commit f95a413b99894dea24645abd791c6b4d200e38f4
Merge: 42d89bc 0127303
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Wed Aug 3 13:06:01 2016 -0400
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Wed Aug 3 13:06:01 2016 -0400

    Merge branch '5.5.z_improve_adding_mult_disks_vmware' into '5.5.z'
    
    5.5.z improve adding multiple disks vmware
    
    This fixes two issues when adding multiple disks to a VMware VM:
    
    1. If you need to add an additional SCSI controller to be able to add a new disk it would fail (e.g.: adding the 16th disk). This is because the open scsi bus was always assumed to be 0
    
    2. If you had non-consecutive free SCSI units it would try to add a disk to a populated location (e.g.: SCSI 0:0 and SCSI 0:2 are populated, adding two disks would try to put them at 0:1 and 0:2). This was because getScsiCandU was only returning the first free disk position, and subsequent unit_numbers were +1 from the first one.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1358488
    
    PR: https://github.com/ManageIQ/manageiq/pull/8899
    
    Cherry-pick was not entirely clean.  All changes to reconfigure.rb had to be pulled out as that model does not exist in 5.5.z.
    MiqVimVm.rb / MiqVimVm_spec.rb are exact replicates of the PR.
    
    See merge request !1031

 gems/pending/VMwareWebService/MiqVimVm.rb          | 31 ++++++++++++++++------
 .../pending/spec/VMwareWebService/MiqVimVm_spec.rb | 26 +++++++++---------
 2 files changed, 36 insertions(+), 21 deletions(-)

Comment 6 Chris Pelland 2017-08-16 17:29:07 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.