Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358451 - User group doesn't work (local user is not selected after refresh or foreman-rake)
Summary: User group doesn't work (local user is not selected after refresh or foreman-...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles
Version: 6.1.9
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 17:52 UTC by Waldirio M Pinheiro
Modified: 2017-03-27 16:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-27 16:30:08 UTC


Attachments (Terms of Use)

Description Waldirio M Pinheiro 2016-07-20 17:52:39 UTC
Description of problem:
After configure the ldap authentication, login with AD user and create a new user group, it's not possible to do the relationship between AD group and local user (this one should be auto when clicking over Refresh in user group conf or via foreman-rake ldap:refresh_usergroups).

Version-Release number of selected component (if applicable):
6.1.9

How reproducible:
Partially (some clients works, some clients not)

Steps to Reproduce:
1. Configure ldap auth
2. Login with one AD account
3. Create one user group, according one AD group
4. In the AD, add the user already created in the foreman in the AD group
5. In the User group, click over Refresh or via cli run the command foreman-rake ldap:refresh_usergroups

Actual results:
It's not possible to see the user login in the Users Columns (User group conf)

Expected results:
Should be possible see the user login in the Users Columns (User group conf)

Additional info:

Comment 9 Bryan Kearney 2017-03-27 16:30:08 UTC
We do not plan on fixing this for Satellite 6.1. I am closing this out as WONTFIX. If you feel this was done in error, please feel free to re-open with additional information. This bug should be fixed in 6.1 since the builds attached to this bug resolved the issue.


Note You need to log in before you can comment on or make changes to this bug.