Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358449 - Summary Screens: Download Summary to PDF toolbar button is missing
Summary: Summary Screens: Download Summary to PDF toolbar button is missing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.7.0
Assignee: Harpreet Kataria
QA Contact: Niyaz Akhtar Ansari
URL:
Whiteboard: ui:button
Depends On:
Blocks: 1359155
TreeView+ depends on / blocked
 
Reported: 2016-07-20 17:40 UTC by Harpreet Kataria
Modified: 2017-01-12 04:54 UTC (History)
7 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1359155 (view as bug list)
Environment:
Last Closed: 2017-01-11 20:23:17 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description Harpreet Kataria 2016-07-20 17:40:07 UTC
Description of problem: Summary Screens: Download Summary to PDF toolbar button is missing


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Go to any CI summary screen, download to PDF button is missing
2.
3.

Actual results: Download to PDF button is missing


Expected results: Should have PDF button available for download.


Additional info:

Comment 3 CFME Bot 2016-07-20 20:45:50 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/69bffac3e40e6108aca4d3d5cdfd0f42f0d2e65e

commit 69bffac3e40e6108aca4d3d5cdfd0f42f0d2e65e
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Jul 20 13:50:21 2016 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Jul 20 16:14:11 2016 -0400

    Moved restful controller check into a mixin in helpers
    
    @showtype should also be passed in to ToolbarChooser.new call. Due to @showtype not being passed in @view_context.send(:restful?) was not getting called at all, after @showtype was passed in @view_context.send(:restful?) call was throwing an error, to fix the error moved restful controller check from toolbar_builder into a mixin so it can be used from other places such as toolbar_chooser to determine which summary_view_tb should be rendered.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1358449

 app/helpers/application_helper.rb                 |  2 ++
 app/helpers/application_helper/toolbar_builder.rb | 17 ++---------------
 app/helpers/application_helper/toolbar_chooser.rb |  7 +++++--
 app/helpers/restful_controller_mixin.rb           |  9 +++++++++
 4 files changed, 18 insertions(+), 17 deletions(-)
 create mode 100644 app/helpers/restful_controller_mixin.rb

Comment 4 Niyaz Akhtar Ansari 2016-10-03 05:38:42 UTC
Verified in version 5.7.0.3.20160927165516_075d0f3


Note You need to log in before you can comment on or make changes to this bug.