Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358443 - [RFE] Retrieve Ansible Tower variable/facts in CloudForms inventory and cross-linking
Summary: [RFE] Retrieve Ansible Tower variable/facts in CloudForms inventory and cross...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: cfme-future
Assignee: John Hardy
QA Contact: Pavol Kotvan
URL:
Whiteboard: tower
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 17:27 UTC by Jerome Marc
Modified: 2017-08-28 15:10 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-28 15:10:12 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jerome Marc 2016-07-20 17:27:09 UTC
Description of problem:
The current host inventory in CloudForms under the Ansible Tower provider does not display Ansible Tower variables/facts. This is required for multiple use cases such as:
- cross-linking hosts with cloud/infrastructure providers
- retrieve parameters e.g. results set as Ansible Tower variables/facts

Version-Release number of selected component (if applicable):
5.6.0.13.20160624114606_13a9153 

How reproducible:
Always

Steps to Reproduce:
1. Configure an Ansible Tower provider in CloudForms
2. Perform a Refresh Relationships and power states (make sure hosts contain variables/facts in Ansible Tower)
3. Look at the host inventory under Ansible Tower provider

Actual results:
No host variable/fact are displayed in CloudForms host inventory.

Expected results:
Host variables/facts should be available from within CloudForms under host inventory.

Additional info:

Comment 3 Chris Pelland 2017-08-28 15:10:12 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.