Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358425 - Remote Execution: Provide better error feedback when attempting to preview templates with no hosts.
Summary: Remote Execution: Provide better error feedback when attempting to preview te...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Remote Execution
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
: 1374355 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 16:02 UTC by jcallaha
Modified: 2018-09-04 17:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 17:46:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 15875 None None None 2016-07-28 11:05:02 UTC

Description jcallaha 2016-07-20 16:02:52 UTC
Description of problem:
If a user, that has no hosts, attempts to preview a Job Template they are presented with the following error:
"Warning! Problem with previewing the template: error during rendering: undefined method 'operatingsystem' for NilClass::Jail (NilClass). Note that you must save template input changes before you try to preview it."

A more helpful error should replace the undefined method error.

Version-Release number of selected component (if applicable):
Satellite 6.2 Beta Snap 20.3

How reproducible:
Always

Steps to Reproduce:
1. Have no hosts assigned to the testing Organization.
2. Navigate to job templates
3. Open one up, and click the 'Preview' button.

Actual results:
"Warning! Problem with previewing the template: error during rendering: undefined method 'operatingsystem' for NilClass::Jail (NilClass). Note that you must save template input changes before you try to preview it."

Expected results:
A more appropriate error message is presented.

Comment 2 Ivan Necas 2016-07-28 11:05:01 UTC
Created redmine issue http://projects.theforeman.org/issues/15875 from this bug

Comment 3 Adam Ruzicka 2016-11-22 12:57:31 UTC
*** Bug 1374355 has been marked as a duplicate of this bug. ***

Comment 5 Bryan Kearney 2018-09-04 17:46:19 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.