Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358406 - OSE Deployments fail at 95% during post_install.yml on task [Save token to known deployment location]
Summary: OSE Deployments fail at 95% during post_install.yml on task [Save token to kn...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHEV
Version: 1.0
Hardware: All
OS: All
urgent
urgent
Target Milestone: ga
: 1.0
Assignee: dgao
QA Contact: Landon LaSmith
Dan Macpherson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 15:40 UTC by Landon LaSmith
Modified: 2016-09-13 16:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:32:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Landon LaSmith 2016-07-20 15:40:35 UTC
Description of problem: During a RHEV+CFME+OSE deployment, OSE fails at 95% during post_install.yml playbook on task [Save token to known deployment location].
Failure message 'sudo: unable to stat /var/db/sudo/foreman: Permission denied

ISO Media Version: 1468874026.174786


How reproducible: 100%


Steps to Reproduce:
1. Install QCI
2. Run fusor-local-nfs-setup to use Sat and NFS server
2. Deploy RHEV + CFME + OSE


Actual results: OSE deployment fails at 95% and log shows failure occurred during execution of post_install.yml


Expected results: OSE deploys successfully

Comment 3 John Matthews 2016-07-20 15:44:46 UTC
Confirmed I saw same with 7/18 ISO.

My ansible.log
  https://gist.github.com/anonymous/b83be41cbd11f905e63cf8ce5f45f484

Comment 6 dgao 2016-07-20 18:06:59 UTC
Fixed in https://github.com/fusor/fusor/pull/1068

Comment 8 John Matthews 2016-07-20 22:40:10 UTC
QCI-1.2-RHEL-7-20160720.t.0-QCI-x86_64-dvd1.iso

Comment 12 Landon LaSmith 2016-07-22 20:02:05 UTC
VERIFIED. OSE deployment proceeded past this task on ISO QCI-1.2-RHEL-7-20160720.t.0

Comment 14 errata-xmlrpc 2016-09-13 16:32:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.