Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358357 (python-pygpgme) - Review Request: python-pygpgme - Python module for working with OpenPGP messages
Summary: Review Request: python-pygpgme - Python module for working with OpenPGP messages
Keywords:
Status: CLOSED ERRATA
Alias: python-pygpgme
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-20 14:55 UTC by Igor Gnatenko
Modified: 2016-08-12 01:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-28 23:53:15 UTC
gwync: fedora-review+


Attachments (Terms of Use)

Description Igor Gnatenko 2016-07-20 14:55:15 UTC
Spec URL: https://ignatenkobrain.fedorapeople.org/for-review/python-pygpgme.spec
SRPM URL: https://ignatenkobrain.fedorapeople.org/for-review/python-pygpgme-0.3-17.fc24.src.rpm
Description:
PyGPGME is a Python module that lets you sign, verify, encrypt and decrypt
files using the OpenPGP format.  It is built on top of GNU Privacy Guard and
the GPGME library.
Fedora Account System Username: ignatenkobrain

This is renaming of existing package "pygpgme" with cleanups, bugfixes, new guidelines and other useful stuff.

Comment 1 Igor Gnatenko 2016-07-20 14:55:59 UTC
UPGRADEPATH is still OK:
[ignatenk@ignatenko obsoletes]$ cat tt.t 
repo system 0 testtags <inline>
#>=Pkg: pygpgme 0.3 16 x86_64
#>=Pkg: python3-pygpgme 0.3 16 x86_64
repo available 0 testtags <inline>
#>=Pkg: python2-pygpgme 0.3 17 x86_64
#>=Prv: pygpgme = 0.3-17
#>=Obs: pygpgme < 0.3-17
#>=Pkg: python3-pygpgme 0.3 17 x86_64

system x86_64 rpm system

poolflags implicitobsoleteusescolors
solverflags allowvendorchange keepexplicitobsoletes bestobeypolicy keeporphans yumobsoletes
job update all packages
[ignatenk@ignatenko obsoletes]$ testsolv tt.t 
Transaction summary:

2 upgraded packages:
  - pygpgme-0.3-16.x86_64 -> python2-pygpgme-0.3-17.x86_64
  - python3-pygpgme-0.3-16.x86_64 -> python3-pygpgme-0.3-17.x86_64

Comment 2 Gwyn Ciesla 2016-07-20 15:54:48 UTC
- rpmlint checks return:

python-pygpgme.src: W: spelling-error %description -l en_US decrypt -> decry pt, decry-pt, decry
The value of this tag appears to be misspelled. Please double-check.

Ignore.

- package meets naming guidelines
- package meets packaging guidelines
- license ( LGPLv2+ ) OK, text in %doc, matches source
- spec file legible, in am. english
- source matches upstream
! package compiles on devel (x86)

mock build succeeds on f24 but fails on rawhide:

test_edit_ownertrust (tests.test_editkey.EditKeyTestCase) ... ERROR
test_edit_quit (tests.test_editkey.EditKeyTestCase) ... ERROR
test_edit_sign (tests.test_editkey.EditKeyTestCase) ... ERROR
test_invalid_parameters (tests.test_genkey.GenerateKeyTestCase) ... ok

======================================================================
ERROR: test_edit_ownertrust (tests.test_editkey.EditKeyTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/pygpgme-0.3/tests/test_editkey.py", line 63, in test_edit_ownertrust
    gpgme.editutil.edit_trust(ctx, key, trust)
  File "/builddir/build/BUILDROOT/python-pygpgme-0.3-17.fc25.i386/usr/lib/python2.7/site-packages/gpgme/editutil.py", line 75, in wrapper
    ctx.edit(key, edit_callback, output)
GpgmeError: (32, 1, u'General error')

======================================================================
ERROR: test_edit_quit (tests.test_editkey.EditKeyTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/pygpgme-0.3/tests/test_editkey.py", line 48, in test_edit_quit
    ctx.edit(key, self.edit_quit_cb, output)
GpgmeError: (0, 32779, u'Bad file descriptor')

======================================================================
ERROR: test_edit_sign (tests.test_editkey.EditKeyTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/pygpgme-0.3/tests/test_editkey.py", line 80, in test_edit_sign
    gpgme.editutil.edit_sign(ctx, key, check=0)
  File "/builddir/build/BUILDROOT/python-pygpgme-0.3-17.fc25.i386/usr/lib/python2.7/site-packages/gpgme/editutil.py", line 75, in wrapper
    ctx.edit(key, edit_callback, output)
GpgmeError: (32, 1, u'General error')

----------------------------------------------------------------------
Ran 55 tests in 49.505s

FAILED (errors=3)


- no missing BR
! no unnecessary BR

Explicit gcc BR is not needed, remove.

- no locales
- not relocatable
- owns all directories that it creates
- no duplicate files
- permissions ok
- %clean ok
- macro use consistent
- code, not content
- no need for -docs
- nothing in %doc affects runtime
- no need for .desktop file 


So it's just the tests in rawhide, and the BR.

Comment 3 Igor Gnatenko 2016-07-20 16:53:19 UTC
(In reply to Jon Ciesla from comment #2)
> - rpmlint checks return:
> 
> python-pygpgme.src: W: spelling-error %description -l en_US decrypt -> decry
> pt, decry-pt, decry
> The value of this tag appears to be misspelled. Please double-check.
> 
> Ignore.
> 
> - package meets naming guidelines
> - package meets packaging guidelines
> - license ( LGPLv2+ ) OK, text in %doc, matches source
> - spec file legible, in am. english
> - source matches upstream
> ! package compiles on devel (x86)
> 
> mock build succeeds on f24 but fails on rawhide:
> 
> test_edit_ownertrust (tests.test_editkey.EditKeyTestCase) ... ERROR
> test_edit_quit (tests.test_editkey.EditKeyTestCase) ... ERROR
> test_edit_sign (tests.test_editkey.EditKeyTestCase) ... ERROR
> test_invalid_parameters (tests.test_genkey.GenerateKeyTestCase) ... ok
> 
> ======================================================================
> ERROR: test_edit_ownertrust (tests.test_editkey.EditKeyTestCase)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File "/builddir/build/BUILD/pygpgme-0.3/tests/test_editkey.py", line 63,
> in test_edit_ownertrust
>     gpgme.editutil.edit_trust(ctx, key, trust)
>   File
> "/builddir/build/BUILDROOT/python-pygpgme-0.3-17.fc25.i386/usr/lib/python2.7/
> site-packages/gpgme/editutil.py", line 75, in wrapper
>     ctx.edit(key, edit_callback, output)
> GpgmeError: (32, 1, u'General error')
> 
> ======================================================================
> ERROR: test_edit_quit (tests.test_editkey.EditKeyTestCase)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File "/builddir/build/BUILD/pygpgme-0.3/tests/test_editkey.py", line 48,
> in test_edit_quit
>     ctx.edit(key, self.edit_quit_cb, output)
> GpgmeError: (0, 32779, u'Bad file descriptor')
> 
> ======================================================================
> ERROR: test_edit_sign (tests.test_editkey.EditKeyTestCase)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File "/builddir/build/BUILD/pygpgme-0.3/tests/test_editkey.py", line 80,
> in test_edit_sign
>     gpgme.editutil.edit_sign(ctx, key, check=0)
>   File
> "/builddir/build/BUILDROOT/python-pygpgme-0.3-17.fc25.i386/usr/lib/python2.7/
> site-packages/gpgme/editutil.py", line 75, in wrapper
>     ctx.edit(key, edit_callback, output)
> GpgmeError: (32, 1, u'General error')
> 
> ----------------------------------------------------------------------
> Ran 55 tests in 49.505s
> 
> FAILED (errors=3)
> 
> 
> - no missing BR
> ! no unnecessary BR
> 
> Explicit gcc BR is not needed, remove.
It is needed. According new packaging guidelines we should specify ALL dependencies.
> 
> - no locales
> - not relocatable
> - owns all directories that it creates
> - no duplicate files
> - permissions ok
> - %clean ok
> - macro use consistent
> - code, not content
> - no need for -docs
> - nothing in %doc affects runtime
> - no need for .desktop file 
> 
> 
> So it's just the tests in rawhide, and the BR.

Will check what's wrong with tests.

Comment 4 Igor Gnatenko 2016-07-25 11:12:57 UTC
Spec URL: https://ignatenkobrain.fedorapeople.org/for-review/python-pygpgme.spec
SRPM URL: https://ignatenkobrain.fedorapeople.org/for-review/python-pygpgme-0.3-18.fc24.src.rpm

Note it requires gnupg-2.1.13 along with gpgme-0.6.0-2.

Tests fixed. Actually it's bug from: https://bugzilla.redhat.com/show_bug.cgi?id=1359521

Comment 5 Gwyn Ciesla 2016-07-25 15:34:21 UTC
Ok, looks good.

APPROVED.

Comment 6 Gwyn Ciesla 2016-07-25 15:38:48 UTC
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/python-pygpgme

Comment 7 Fedora Update System 2016-07-25 16:40:46 UTC
gpgme-1.6.0-3.fc23 python-pygpgme-0.3-18.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-33b89975fe

Comment 8 Fedora Update System 2016-07-25 16:41:29 UTC
gpgme-1.6.0-3.fc24 python-pygpgme-0.3-18.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-198d93bc53

Comment 9 Fedora Update System 2016-07-28 04:19:24 UTC
gpgme-1.6.0-3.fc23, python-pygpgme-0.3-18.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-33b89975fe

Comment 10 Fedora Update System 2016-07-28 06:01:55 UTC
gpgme-1.6.0-3.fc24, python-pygpgme-0.3-18.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-198d93bc53

Comment 11 Fedora Update System 2016-07-28 23:53:08 UTC
gpgme-1.6.0-3.fc24, python-pygpgme-0.3-18.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-08-12 01:24:21 UTC
gpgme-1.6.0-3.fc23, python-pygpgme-0.3-18.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.