Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1358339 - [FC24] failing to deploy host
Summary: [FC24] failing to deploy host
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: ovirt-host-deploy
Classification: oVirt
Component: Core
Version: master
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On: 1361888
Blocks: oVirt_Fedora24_Support 1416854
TreeView+ depends on / blocked
 
Reported: 2016-07-20 14:34 UTC by Sandro Bonazzola
Modified: 2017-12-22 07:44 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
In Fedora 24 otopi does not support Python3 natively and Python2 libraries are missing by default. Manually install the Python2 packages by running 'dnf install python2-dnf.noarch' so that ovirt-host-deploy will continue to work.
Clone Of:
: 1416854 (view as bug list)
Environment:
Last Closed: 2017-01-26 15:37:25 UTC
oVirt Team: Integration
rule-engine: ovirt-4.1+
ylavi: Triaged+
rule-engine: planning_ack+
rule-engine: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)
log collector report (deleted)
2016-07-20 14:34 UTC, Sandro Bonazzola
no flags Details
host deploy log (deleted)
2017-01-26 15:22 UTC, Petr Matyáš
no flags Details

Description Sandro Bonazzola 2016-07-20 14:34:50 UTC
Created attachment 1182132 [details]
log collector report

Trying to add an host on ovirt master running on FC24 with FC24 host.
Failing to execute ovirt-host-deploy.
Attached log collector report.
Oved, can you please review the engine logs?

Comment 1 Red Hat Bugzilla Rules Engine 2016-07-20 14:34:55 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 2 Oved Ourfali 2016-07-20 14:38:38 UTC
Piotr will check that next week.

Comment 3 Piotr Kliczewski 2016-07-25 14:01:03 UTC
In host deploy logs I see:

2016-07-20 16:20:13 DEBUG otopi.context context._executeMethod:142 method exception
Traceback (most recent call last):
  File "/tmp/ovirt-MwlkMSyicH/pythonlib/otopi/context.py", line 132, in _executeMethod
    method['method']()
  File "/tmp/ovirt-MwlkMSyicH/otopi-plugins/otopi/network/hostname.py", line 54, in _internal_packages
    self.packager.install(packages=('iproute',))
  File "/tmp/ovirt-MwlkMSyicH/pythonlib/otopi/packager.py", line 98, in install
    raise NotImplementedError(_('Packager install not implemented'))
NotImplementedError: Packager install not implemented

which fails host deploy:

2016-07-20 16:20:13,366 ERROR [org.ovirt.engine.core.uutils.ssh.SSHDialog] (org.ovirt.thread.pool-8-thread-2) [64bb8ca6] Exception: java.io.IOException: Command returned failure code 1 during SSH session 'root@hyperv.home'
	at org.ovirt.engine.core.uutils.ssh.SSHClient.executeCommand(SSHClient.java:503) [uutils.jar:]
	at org.ovirt.engine.core.uutils.ssh.SSHDialog.executeCommand(SSHDialog.java:317) [uutils.jar:]
	at org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase.execute(VdsDeployBase.java:563) [bll.jar:]
	at org.ovirt.engine.core.bll.hostdeploy.InstallVdsInternalCommand.installHost(InstallVdsInternalCommand.java:169) [bll.jar:]
	at org.ovirt.engine.core.bll.hostdeploy.InstallVdsInternalCommand.executeCommand(InstallVdsInternalCommand.java:90) [bll.jar:]

Comment 4 Sandro Bonazzola 2016-08-08 12:00:55 UTC
Resolving with Known Issue documentation:
Until otopi will support Python 3, python2-dnf.noarch is needed on the host.

Verified working with:
ovirt-vmconsole-1.0.4-0.0.master.20160805075548.git6c59386.fc24.noarch
vdsm-4.18.999-374.git6f033fe.fc24.x86_64

and

otopi-1.6.0-0.0.master.20160805120739.git083ac7b.fc24.noarch
ovirt-host-deploy-1.5.2-0.0.master.20160805053438.git6cd75db.fc24.noarch
ovirt-engine-4.1.0-0.0.master.20160807181833.git06965fe.fc24.noarch

Comment 5 Greg Sheremeta 2016-11-30 14:02:27 UTC
In case it helps anyone, I was getting this problem on FC24 <--> FC24 as well, with ovirt-release-40.rpm installed. I had to switch to ovirt-release-master.rpm on both host and engine, and update otopi and ovirt-host-deploy on the engine. Works now.

Comment 6 Sandro Bonazzola 2016-12-12 13:55:34 UTC
The fix for this issue should be included in oVirt 4.1.0 beta 1 released on December 1st. If not included please move back to modified.

Comment 7 hlmasterchief93 2017-01-02 22:54:19 UTC
Still fail with oVirt 4.1.0 beta 2 on Fedora 24. Need to manually install python2-dnf.

Packages:

ovirt-hosted-engine-setup-2.1.0-0.0.master.20161221071740.git46cacd3.fc24.noarch
ovirt-release41-pre-4.1.0-0.6.beta2.20161221025826.gitc487776.el7.centos.noarch


Logs:

Traceback (most recent call last):
  File "/usr/share/otopi/plugins/otopi/packagers/dnfpackager.py", line 150, in _boot
    constants.PackEnv.DNF_DISABLED_PLUGINS
  File "/usr/share/otopi/plugins/otopi/packagers/dnfpackager.py", line 60, in _getMiniDNF
    from otopi import minidnf
  File "/usr/lib/python2.7/site-packages/otopi/minidnf.py", line 16, in <module>
    import dnf
ImportError: No module named dnf

Comment 8 Petr Matyáš 2017-01-26 15:22:08 UTC
Created attachment 1244793 [details]
host deploy log

This is still not fixed in ovirt 4.1 experimental

Comment 9 Red Hat Bugzilla Rules Engine 2017-01-26 15:22:57 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 10 Sandro Bonazzola 2017-01-26 15:37:25 UTC
We're not going to fix this in 4.1, closing this as DEFERRED with Knonwn Issue doctext in order to get this documented in release notes.
I'll clone this bug to 4.2.


Note You need to log in before you can comment on or make changes to this bug.